[ntp:questions] Re: PPS working or not? FreeBSD 5.4

David J Taylor david-taylor at blueyonder.co.not-this-bit.nor-this-part.uk.invalid
Thu Feb 2 07:17:43 UTC 2006


Harlan Stenn wrote:
>>>> In article <LY8Df.11489$wl.11104 at text.news.blueyonder.co.uk>,
>>>> "David J Taylor"
>>>> <david-taylor at blueyonder.co.not-this-bit.nor-this-part.uk.invalid>
>>>> writes:
>
> John> 5) [Make sure] you have "options PPS_SYNC" in your kernel config
>
> David> 5 - I have not done that explicity.  How could I check that,
> and David> change it if required?  It's been 10+ years since I ran
> UNIX.
>
> Assuming an x86 box, put the following in /usr/src/sys/i386/conf/PPS:
>
> #
> # PPS -- Generic kernel configuration file for FreeBSD/i386 PPS
> #
>
> include GENERIC
>
> ident PPS-GENERIC
>
> options PPS_SYNC
>
> and then add the following line to /etc/make.conf:
>
> KERNCONF=    PPS GENERIC
>
> (Assuming you want "cd /usr/src && make buildkernel installkernel) to
> build both kernels and only install the PPS kernel).
>
> I also add the lines:
>
> link cuaa1 refclock-0
> link    cuaa1   pps0
>
> to the end of /etc/devfs.conf, and *sometimes* it looks like those
> links are not created soon enough in the boot sequence, but it's
> sporadic and I have not had time to chase it down yet.
>
> H

Harlan,

Just to report back:

- I added the options PPS_SYNC and recompiled the kernel.

- I followed the instructions at:
  http://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/kernelconfig-building.html
  using the "traditional" procedure 1.

- I didn't appear to need to add the lines to /etc/devfs.conf

- I had already added the following line to /etc/rc.local :
  ln -s /dev/cuaa0 /dev/gps1

I've included all this information in:
  http://www.david-taylor.myby.co.uk/ntp/FreeBSD-GPS-PPS.htm

The current status can be seen here:
  http://www.david-taylor.myby.co.uk/mrtg/daily_ntp.html

Thanks for your help.

David 





More information about the questions mailing list