[ntp:questions] Re: Oncore Reference Driver Problem

Richard B. Gilbert rgilbert88 at comcast.net
Sat Feb 11 20:08:33 UTC 2006


Thomas Laus wrote:

> Was there a change made to the Motorola Oncore reference clock driver
> between NTP 4.2.0 and the latest stable version, 4.2.0a-20060127?
> 
> I did a port upgrade on my FreeBSD 6.0 system yesterday and the clock
> driver stopped reading my Oncore VP.  I looked over the Oncore reference
> clock source code and the updating file for any required configuration
> file changes and did not find any.  The changelog showed some Leap
> Second bug fixes in December, but no required modifications to
> /etc/ntp.conf or /etc/oncore0.
> 
> I upgraded to stable after  doing a 'make deinstall' on the 4.2.0
> original version.  I ran make and installed the latest stable version
> and sent 'SIGHUP' to the daemon.  All of my internet servers worked, but no
> reply was seen from my Oncore refclock.  I reinstalled version 4.2.0 and
> sent a SIGHUP to the ntp daemon and everything went back to normal.
> 
> I got the same results when building and installing the current devel-
> opment snapshot.
> 
> Tom
> 

Sounds like Bug 546
https://ntp.isc.org/bugs/show_bug.cgi?id=546

I believe the maintainer is shoveling like mad, trying to find his desk!

It may be a while before this is fixed!

I've looked for the cause myself without result so far.   A diff of the 
two versions reveals that several hundred lines of code have been 
changed, for what reason I cannot say.  I used the VMS difference 
utility which has the ability to ignore comments and white space so all 
the changes I saw seem to have been substantive rather than cosmetic.

I must say, I found the code quite difficult to follow!




More information about the questions mailing list