[ntp:questions] Re: SUSE OSS 10 NTPD Clock Drift

Mark Hansen meh at NOSPAMwinfirst.com
Thu Jan 19 19:45:08 UTC 2006


On 01/19/06 11:10, Richard B. Gilbert wrote:
> garskof at gmail.com wrote:
> 
>>I have 'ntpd' running on a SUSE OSS 10 server that has very bad clock
>>drift. This box drifts about 60 to 90 min per day. The 'ntpd' service
>>is up and running, and it correctly resets the clock on boot (on
>>startup of ntpd), but never resets the clock again.
>>
>>How do I tell ntpd to check the time with a time service a few times a
>>day to help keep this machine on track? I can not find any
>>documentation that tells me how to set how often ntpd checks its
>>sources for updates.
>>
>>Thanks for any and all info.
>>
>>--
>>garskof
>>
>>  
>>
> You are asking for more than ntpd can do.   The limit on clock frequency 
> correction is 500 parts per million (PPM) which works out to about 42 
> minutes per day.   Either fix the hardware, replace the hardware, or 
> forget about having the correct time.  (Actually, you could run ntpdate 
> as a cron job every 30 minutes if you don't mind the clock "jumping" 
> when it's reset.)
> 
> Actually, it may not be the hardware.  Some flavors of Linux have a 
> problem with losing clock interrupts when they get busy.  If you have a 
> kernel parameter called "HZ" and if it's set to 1000, setting it to 100 
> might help.

I don't know if this will help, but I had similar problems when running
on an dual-processor machine. This was with an older version of Linux,
and I worked around it by adding a parameter to the boot arguments,
although I can't remember now what that was - google should help if
this is your problem.




More information about the questions mailing list