[ntp:questions] Broadcastclient

Joel Shellman joelshellman at yahoo.com
Fri Jan 27 17:47:06 UTC 2006

I'm trying to set up a broadcast client, but it
doesn't seem to be receiving the broadcasts.

I ran:

tcpdump |grep

on the client machine and it did show:

12:40:22.014304 IP > NTPv4, Broadcast, length 48

So it seems that the broadcasts are getting to the
client box, but the client doesn't seem to be doing
anything about it. I run ntpd -dd and it shows
absolutely nothing about receiving anything (shows
nothing but an occasional auth_agekeys:... line) and
ntpq -p says no association ids returned.

Here's the client ntp.conf:

restrict default nomodify notrap noquery
driftfile /var/lib/ntp/drift

Also, on startup of ntp -dd, it does show:

interface 3:  fd=7,  bfd=-1,  name=eth0,  flags=0x9, 
              sin=  bcast=, 
init_io: maxactivefd 7
local_clock: time 0 clock 0.000000 offset 0.000000
freq 0.000 state 0
getnetnum given, got
addto_syslog: frequency initialized 0.160 PPM from
local_clock: time 0 clock 0.000000 offset 0.000000
freq 0.160 state 1
bind() fd 9, family 2, port 123, addr,
flags for fd 9: 04002
io_setbclient: Opened broadcast client on interface 3,
socket: 9
io_setbclient: Opened broadcast clients
report_event: system event 'event_restart' (0x01)
status 'sync_alarm, sync_unspec, 1 event,
event_unspec' (0xc010)

So it looks like it's trying to listen on the
broadcast port.



ps. running version ntpd 4.2.0a at 1.1190-r on CentOS 4.2

Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 

More information about the questions mailing list