[ntp:questions] Re: PPS working or not? FreeBSD 5.4

David J Taylor david-taylor at blueyonder.co.not-this-bit.nor-this-part.uk.invalid
Sun Jan 29 19:46:51 UTC 2006


John Pettitt wrote:
> David J Taylor wrote:
>> I just spent an interesting few hours setting up a FreeBSD 5.4
>> system from scratch, and interfacing it to a Garmin GPS 18 LVC.
>> Well, there was a lot of help in the Web, and it must be 10 or more
>> years since I messed with UNIX.
>>
>> I'm getting what seem to be sensible results, but the jitter from
>> the GPS seems to be higher than some of the Internet servers (3ms
>> versus 1ms), so I'm wondering if the PPS signal on the DCD line is
>> being used at all. I've set flag3 = 1 in the fudge command.
>>
>> Any suggestions?  I'm really new to FreeBSD so I might have missed
>> the glaringly obvious!
>>
>> Thanks,
>> David
>>
>>
>
> I have the same setup.
>
> Jitter from a GPS18LVC should be on the order of 3-5 microseconds so
> I think your PPS is not working.
>
> Things to check
>
> 1) PPS is wired to DCD
> 2) you are on a real serial port not a USB one
> 3) you made the sym link from /dev/pps0 to /dev/ttyd?
> 4) you have pps enabled in the GPS18 (download the garmin utils and
> turn off all the NMEA stuff you don't need and make sure PPS is on)
> 5) you have "options PPS_SYNC" in your kernel config
>
> John

John,

Many thanks for that.

1 is OK - I can see the pulse with a 'scope on pin 1 of the DB9 connector

2 - OK

3 - I'm using COM1 for the GPS, and the sym link I found elsewhere was:

  ln -s cuaa0 gps1

(my ntp.conf includes server 127.127.20.1)

So should I be linking cuaa0 or ttyd0, and should it be to pps0 or pps1? 
I have tried "ln -s ttyd0 pps1".  Ntpdc -c kern shows:

pixie# ntpdc -c kern
pll offset:           -0.0408704 s
pll frequency:        100.840 ppm
maximum error:        0.126969 s
estimated error:      0.007626 s
status:               2001  pll nano
pll time constant:    6
precision:            1e-09 s
frequency tolerance:  496 ppm

4 - is OK, I can see the pulse and just the GPRMC messages.

5 - I have not done that explicity.  How could I check that, and change it 
if required?  It's been 10+ years since I ran UNIX.

Thanks,
David 





More information about the questions mailing list