[ntp:questions] Re: Slew mode check for XNTP

Sasikumar Jayaraman sasi05 at gmail.com
Thu Jul 27 00:57:55 UTC 2006


After changing the image path in registry as ntpd.exe -x -g, I haved changed
the time of 2 systems ahead of clock source. But both had sycn with clock
source withing 20 minutes.

System A - 3 minutes ahead of source

System B - 8 minutes ahead of source.

The default option is that if the offset is less than 128 seconds, it should
slew the clock. I tried changing the timing difference as 2 minutes. But I
could see clock is changed in one shot to clock source.

Not that it took hours together to complete the sync up.


Last try I would do this instead of ntpdate. ntpd.exe -x -g -q with 5
minutes time ahead of clock source.

I am getting a feeling that XNTP for Windows slew options doesn't work well.
I know W32Time works well. 3 minutes time change took 1 week for correction.



Thanks,
Sasi.




On 7/27/06, David Woolley <david at djwhome.demon.co.uk> wrote:
>
> In article <a8e7dcda0607260549j3687bf39t25719705cd15a28c at mail.gmail.com >,
> sasi05 at gmail.com (Sasikumar Jayaraman) wrote:
>
> > I am running XNTP version 4.2.0 as per ntpdc -c version output.
>
> There's no such version.  However the other information suggests
> that you are actually running version 4.2.0 of *ntpd*.
>
> > C:\>ntpdc -c version
>
> This gives the version of the ntpdc program.  To get the version of ntpd,
> you would need to use ntpq to issue an rv 0 command.
>
> > C:\>ntpdate -B ntp01-ams
>
> ntpdate is not ntpd.
>
> > Looking for host ntp01-ams and service ntp
> > host found : ntp01-ams.lab.net
> >
> > The -b option is required by ntpdate on Windows NT platforms
>
> I believe this is because Unix has a system call which says slew the
> clock until you have accumulated this many ticks of correction, whereas
> there is no equivalent system call on Windows.  Windows does have a
> system call to change the effective clock frequency, which is available
> to nptd, and, in fact must be used when it is not in error recovery
> mode, but is not suitable for ntpdate, as it would mean that ntpdate
> couldn't exit until the slew completed.
>
> > Also I tried changing the registry setting to include  -x and -g option.
>
> For ntpd version 4.2.0, -x increases the step threshold from 128ms to
> 10 minutes.  If your time error was more than 10 minutes, you would still
> get a step.
>
>                    case 'x':
>                        clock_max = 600;
>                        break;
>
> You would need to use a tinker command to completely disable stepping.
>
> > Can I conclude that slew mode operation is not available for Windows
> version
> > of  XNTP?
>
> No, and given that stepping is the special case of clock adjustment, I
> don't
> think a more detailed examination of the NT specific parts of the code
> will
> indicate any special handling for NT, but without the time to read all
> the code, or an NT to try it on, I can't be 100% sure.
>
> _______________________________________________
> questions mailing list
> questions at lists.ntp.isc.org
> https://lists.ntp.isc.org/mailman/listinfo/questions
>



More information about the questions mailing list