[ntp:questions] Linux 2.6.15.1 & Oncore M12+ & PPSkit-light - yey

draziw at gmail.com draziw at gmail.com
Fri Mar 24 05:34:58 UTC 2006


An fyi for those googling keywords, and a quick thanks to Ulrich, Reg
and the rest of the npt contributors..
I'm happily running again with a 2.6 kernel.  2.6.15.1 +
PPSkit-light-alpha-3328m-2.6.15.1.diff +
ntp-dev-4.2.0b-rc1-20060322.tar.gz.

After getting the kernel and patch in, checked with ppsapitest.c that
the PPS was appearing.  Rebuilt my ntp with ./configure --enable-ONCORE
- and it was up.  Not a lot of cycles yet, but so far things look good
to my untrained eye.  (My plan is to pull the other st 1 servers after
a bit more testing, and put in a st2 as backup)

Cheers,
Ryan

ntpq -p
     remote           refid      st t when poll reach   delay   offset
jitter
==============================================================================
+time.nist.gov   .ACTS.           1 u   49   64  377   62.821    0.483
 0.533
-timekeeper.isi. .GPS.            1 u   54   64  377   23.499    1.286
16.040
+tick.ucla.edu   .PSC.            1 u   60   64  377   14.682    0.810
 0.489
-gatekeeper.no-s .GPS.            1 u   46   64  377   40.506   -1.346
13.604
 LOCAL(0)        .LOCL.           5 l   50   64  377    0.000    0.000
 0.001
*GPS_ONCORE(0)   .GPS.            0 l   11   16  377    0.000   -0.001
 0.001

ntptime
ntp_gettime() returns code 0 (OK)
  time c7ce033c.0f28a000  Thu, Mar 23 2006 21:33:48.059, (.059214),
  maximum error 7489 us, estimated error 3 us
ntp_adjtime() returns code 0 (OK)
  modes 0x0 (),
  offset 0.000 us, frequency -159.136 ppm, interval 4 s,
  maximum error 7489 us, estimated error 3 us,
  status 0x1 (PLL),
  time constant 0, precision 1.000 us, tolerance 496 ppm,
  pps frequency -59.230 ppm, stability 0.000 ppm, jitter 0.000 us,
  intervals 0, jitter exceeded 0, stability exceeded 0, errors 0.




More information about the questions mailing list