[ntp:questions] Re: NMEA refclock - PPS not working

dave morgan morgad at eclipse.co.uk
Mon May 15 13:19:13 UTC 2006


On Mon, 15 May 2006 08:34:21 +0100, "R Jenkins" <not at pub.lished> wrote:

>"Harlan Stenn" <stenn at ntp.isc.org> wrote in message 
>news:ywn9ody0dx0z.fsf at ntp1.isc.org...
>> The time reported by your NMEA clock is far enough away from your other 2
>> sources that ntpd is not believing your NMEA clock.
>>
>> H
>
>Hi,
>
>it's supposed to be working with PPS; that is the absolute time reference.
>
>I'm using a Garmin GPS25 as per the example in the NMEA Refclock 
>documentation.
>It has only the $GPRMC output string turned on, at once per second.
>
>Others are using successfully using exactly the same hardware - e.g. from 
>Dave Morgan in reply to my previous topic:
>"I am running a gps25hlv direct with no extra conversion for the PPS but 
>with a 2.4.29-NANO kernel on a Debian/Woody system."
>

a couple of random thoughts

a) Have you tried setting ntp.conf to look at the other edge of the PPS
pulse?

b) Section 4c of the PPS kit install instructions (for PPS kit 2.1.5)
caught me out for a couple of weeks. Have you copied both the updated
timepps.h and timex.h files so the NTP compile can see them? (I
initially only copied one)

Dave
-- 
http://www.morgad.no-ip.info/index.html    gpg:0x64B5E037 
Distributed Proofreaders: http://www.pgdp.net
The NTP server pool http://www.pool.ntp.org
http://stellar-attraction.com/



More information about the questions mailing list