[ntp:questions] Re: Box not synchronizing

Harlan Stenn stenn at ntp.isc.org
Wed May 24 22:18:31 UTC 2006


>>> In article <a10b0c8a0605241412x3a3884b2qc1d075edec954a37 at mail.gmail.com>, 1.41421 at gmail.com (JCA) writes:

JCA>    I have three Linux boxes, namely, A, B, and C, in my LAN. I use C as
JCA> the NTP server for my LAN. C, in turn, gets its synchronization from
JCA> some external NTP server.

JCA>   Both A and B use the same (very simple) ntp.conf configuration file:

JCA> server 127.127.1.0 # local clock
JCA> fudge 127.127.1.0 stratum 10

You don't need the previous 2 lines.  A and B will follow C.  If you want A
and B to provide "backup" time service to the rest of your net then this is
almost, but no quite, the way to do it.

JCA> server 192.168.0.1 # IP address of C in my LAN

I notice you are not using iburst.

JCA> driftfile /etc/ntp/drift
JCA> multicastclient # listen on default 224.0.1.1
JCA> broadcastdelay 0.008

I have not played with multicast or broadcast much.

JCA>    The problem is that while A gets its synchronization from C all
JCA> right, B does not. In A, the ouput from

JCA>     ntpq -pn

JCA> is ...

JCA> whereas when invoked from B, the command just hangs for a few seconds,
JCA> finally returning the following:

JCA> localhost: timed out, nothing received ***Request timed out

JCA>    Can anybody give ideas so as to what is going here? Notice that I
JCA> can synchronize B with C by hand by issuing the ntpdate command in B.

I would phrase it as you can set the time on B by running 'ntpdate C'.

The timeout implies that ntpd is not running on B.  Anything in the log?

Have you seen http://ntp.isc.org/Support/StartingNTP ?  There is other stuff
there that will also be useful.

H




More information about the questions mailing list