[ntp:questions] NTPD not receiving any response from timservers

lingsmail at gmail.com lingsmail at gmail.com
Mon Nov 6 22:59:09 UTC 2006


On Nov 6, 9:58 pm, Steve Kostecke <koste... at ntp.isc.org> wrote:
> On 2006-11-06, lingsm... at gmail.com <lingsm... at gmail.com> wrote:
>
> > I'm trying to set up NTPD on a gentoo box to serve time to my network.
> > Needless to say, it's not working. It remains as a stratum 16 server,
> > because it is not syncing.<snip>
>
> > remote           refid  st t when poll reach   delay  offset  jitter
> >=====================================================================
> > ntp.demon.co.uk .INIT.  16 u    -   64    0    0.000  0.000   0.000
> > box2.martinradf .INIT.  16 u    -   64    0    0.000  0.000   0.000
> > hall.inhouse-so .INIT.  16 u    -   64    0    0.000  0.000   0.001This is showing that your ntpd has not received any NTP packets from
> those time servers.
>
> And here's why:
>
> > server ntp.demon.co.uk prefer iburst
> > restrict 158.152.1.76 nomodify NOSERVE
> > server 81.187.65.110 iburst
> > restrict 81.187.65.110 nomodify NOSERVE noquery notrap
> > server 213.170.141.38 iburst
> > restrict 213.170.141.38 nomodify NOSERVE noquery notrapnoserve == Deny all packets except ntpq and ntpdc queries.
>
> noquery == Deny all ntpq and ntpdc queries.
>
> You've told ntpd to completely ignore your time servers. Try removing
> the noserve and restarting ntpd.

Heh heh, thank you.  I was under the (obviously mistaken) impression
that noserve meant 'don't serve time to this server'.
Hm, and re-reading the document you referenced
(http://ntp.isc.org/Support/AccessRestrictions), I can see why:
     "noserve -- "Do not serve time to this host/subnet.""
To be fair that is trimming the article, it goes on to say:
     "This option is really intended to be used when you want to allow
a host/subnet to access your ntpd only for monitoring and/or remote
configuration."  ... which I clearly ignored

However the official documentation (which I hadn't read) is nicely
unambiguous:
 "noserve
    Deny all packets except ntpq and ntpdc queries."

Cheers,
Ling




More information about the questions mailing list