[ntp:questions] Local clock question with dialup connection

Nigel Henry cave.dnb at tiscali.fr
Tue Apr 17 12:02:13 UTC 2007


On Tuesday 17 April 2007 03:25, Harlan Stenn wrote:
> >>> In article <200704162309.24517.cave.dnb at tiscali.fr>,
> >>> cave.dnb at tiscali.fr (Nigel Henry) writes:
>
> Nigel> djmons at localhost djmons]$ /usr/sbin/ntpq
> ntpq> pe
> Nigel> localhost.localdomain: timed out, nothing received ***Request timed
> Nigel> out
>
> This looks like ntpd is not running at the time you did this.
>
> H
Yeh I suppose that's the obvious conclusion.

I booted up again this morning, and ran ntpq> pe before connecting to the I 
nternet, and got the same result as above. Then connected to the Internet, 
and ran pe again, and got the "No association ID's returned" reply.

Services shows the daemon is running, and lists a couple of PID's that I 
checked using ps auxw . See below

ntp       2875  0.0  2.1  5392 5392 ?        SL   10:27   0:00 ntpd -U ntp 
-p /var/run/ntpd.pid -g

root      4531  0.0  2.1  5392 5392 ?        S    10:31   0:00 ntpd -U ntp 
-p /var/run/ntpd.pid -g

This is odd. I've just stopped ntpd, and PID 2875 has disappeared under 
"services" status, but the status window still shows ntpd running, but only 
with PID 4531.  Press stop again, and it returns stop failed, but now the 
status says "ntpd stopped". Now press start, and status says,
ntpd (pid 14218) is running, and ntpq> pe now shows the server list.

ntp      14218  0.0  1.9  4912 4912 ?        SL   11:52   0:00 ntpd -U ntp 
-p /var/run/ntpd.pid -g
root     14494  0.0  1.9  4912 4912 ?        S    11:53   0:00 ntpd -U ntp 
-p /var/run/ntpd.pid -g

Harlan. What you say in your next post about, if I read it correctly, is that 
the daemon is being started too early in the boot process.

What I might try is putting a couple of lines in rc.local to stop and then 
start ntp.

Nigel.



More information about the questions mailing list