[ntp:questions] Unresolved Symbol

Aggie c.kevin.lam at gmail.com
Thu Aug 9 23:49:40 UTC 2007


Thanks Harlan Stenn,

After I edited the adjtime.c with casey's cote, I'm able to load ntpd
with no warning about the unresolved symbol. What's next?? How do I
test if this ntpd is working or not? I tried to just type ntpd at the
prompt and see if it runs, but it gave me error, here's what shown:

Machine Check
Program counter:    0x006c732c
Status Register:     0x00000000

Extra information:
func:    nextOption
args:     pOpts
value:     0x6DDFC0
{name:     p0ptState
value:      0x6FAB90
file:    c:/cygwin/.......................
line:      479
column:          0

0x006dfffc ustotslo+0x3CC   : optionProcess (0x6A0000 6035104 0x1)
0x006cd728 optionProcess+0x68 : doRegularOpts (0x6FADC8)
0x006c7894 doRegularOpts+0x7C : doRegularOpts (0x6DDFC0)
0x006c7894 doRegularOpts+0x7C : nextOption (0x6DDFC0 0x6FAB90)
0x006c732c nextOption+0x2C :  ? ( )

==================
What's going on? why is there error at nextOption()?? i didn't change
the source code though. And is it because the way I run ntpd? do I
need to do something like "ntpd -c ntp.conf"

Thank you very much!!





More information about the questions mailing list