[ntp:questions] Unresolved Symbol

Richard B. Gilbert rgilbert88 at comcast.net
Fri Aug 10 00:19:14 UTC 2007

Aggie wrote:
> Thanks Harlan Stenn,
> After I edited the adjtime.c with casey's cote, I'm able to load ntpd
> with no warning about the unresolved symbol. What's next?? How do I
> test if this ntpd is working or not? I tried to just type ntpd at the
> prompt and see if it runs, but it gave me error, here's what shown:
> Machine Check
> Program counter:    0x006c732c
> ==================
> What's going on? why is there error at nextOption()?? i didn't change
> the source code though. And is it because the way I run ntpd? do I
> need to do something like "ntpd -c ntp.conf"
> Thank you very much!!

I think you need the configuration file, ntp.conf.  Either put it in the 
default location where the program will find it or pass the location of 
the file in the command line.

Without the configuration file, ntpd will not know how to find its 
servers!  It may have some desparation default that I don't know of but 
I wouldn't want to count on it!

More information about the questions mailing list