[ntp:questions] FreeBSD refclock error

Kevin Oberman oberman at es.net
Mon Aug 13 15:04:36 UTC 2007

> Date: Sun, 12 Aug 2007 17:05:32 -0700
> From: David Newman <dnewman at networktest.com>
> Sender: questions-bounces+oberman=es.net at lists.ntp.org
> Hash: SHA1
> On 9/6/06 10:46 PM, Terje Mathisen wrote:
> > David Newman wrote:
> >> Hash: SHA1
> >>
> >> Garrett Wollman wrote:
> >>> In article <44FF015A.6060600 at networktest.com>,
> >>> David Newman <dnewman at networktest.com> wrote:
> >>>
> >>>> refclock_newpeer: clock type 26 invalid
> >>>>
> >>>> This is with the stock install of FreeBSD; I didn't install ntp from
> >>>> ports, and I have not recompiled the kernel. (If I do need to recompile
> >>>> the kernel, please let me know what option(s) to use.)
> >>> You need to recompile ntpd.  FreeBSD ships ntpd by default without
> >>> refclock drivers.
> >>
> >> - From ports? From source? Either way, where do I spec compile-time
> >> option(s), and which option(s) do I need for the 58503A?
> > 
> > 'Use the Source, Luke!'
> > 
> > I.e. by all means grab the official distribution from
> > http://www.ntp.org/ ! FreeBSD is pretty much _the_ preferred platform
> > for the reference installation.
> > 
> Apologies for what is basically a FreeBSD question: How to ensure that
> the ISC distro and not the one included with FBSD gets started on boot?
> Some 11 months after the above thread I finally got around to grabbing
> the ISC source and building it to support an HP 58503A GPS receiver as a
> refclock.
> The good news: The ISC build installs into /usr/local/bin/ntpd and sees
> the HP receiver just fine.
> Now the problem: The startup script in /etc/rc.d/ntpd points to the
> existing binary in /usr/sbin/ntpd. Even if I edit the rc.d file (a bad
> idea, since I presume the script may be overwritten during upgrades),
> the script still calls /usr/sbin/ntpd and not the ISC version that's in
> /usr/local/bin.
> Again, apologies for the FreeBSD-for-dummies question, but what's the
> right way to get the ISC version to start each time this system reboots?
> Do I just take the ntpd_enable out of rc.conf and add my own stuff to
> rc.local?
> This is for ntpd 4.2.4p3 on FBSD 6.2-RELENG on i386.

If you install the ntp port, you will get 4.2.3p51. It will install all
files in /usr/local unless you set up the environment to do otherwise.

To make this the ntp that will be run, edit /etc/rc.conf to contain:
ntpd_enable="Yes"                # Run ntpd Network Time Protocol (or NO).
ntpd_program="/usr/local/sbin/ntpd" # path to ntpd, if you want a different one.

That should do the trick. I also recommend marking some high-stratum
servers as 'iburst' so your initial time sync will be fast and setting
in /etc/rc.conf. If you do this, you should not enable ntpdate (which is
R. Kevin Oberman, Network Engineer
Energy Sciences Network (ESnet)
Ernest O. Lawrence Berkeley National Laboratory (Berkeley Lab)
E-mail: oberman at es.net			Phone: +1 510 486-8634
Key fingerprint:059B 2DDF 031C 9BA3 14A4  EADA 927D EBB3 987B 3751
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 224 bytes
Desc: not available
URL: <http://lists.ntp.org/pipermail/questions/attachments/20070813/376a15c5/attachment.pgp>

More information about the questions mailing list