[ntp:questions] Unable to use SUSE Linux for time synchronization.

sandy sandypossible at gmail.com
Wed Feb 14 11:52:09 UTC 2007


192.168.1.121 is the SNTP server( windows) in LAN.

I tried every combination today and still unable to sync my SUSE to
external time servers. :(

My ntp.conf is  ( excluding commented portion ):
---------------------------------
server clock.redhat.com
server clock2.redhat.com
server ns1.tuxfamily.org
server time.nist.gov

#server 127.127.1.0             # local clock (LCL)
fudge  127.127.1.0 stratum 2    # LCL is unsynchronized

authenticate no

driftfile /var/lib/ntp/drift/ntp.drift # path for drift file
broadcastdelay 0.008
keys /etc/ntp.keys              # path for keys file
-----------------------------------------

I am trying to use SUSE linux as NTP server. As this NTP server is
sending  Leap indicator as "Alarm condtion ( clock not synchronized)",
sntp client is refusing to accept the time stamp. I am trying to over
come this flag setting.

I executed the below command,
# ntpdate -u clock2.redhat.com
14 Feb 17:16:07 ntpdate[17992]: no server suitable for synchronization
found

Infact, any server I use in the above command, the same error I get.
Important is I am unable to ping these servers. But firewall is
disabled. I have access to internet as I can browse and surf. I used
"ntpdate", "ntptrace" to find what is wrong. I am unable to find out.
Do I need to be able to ping to these servers ? I am confused as
firewall is disabled but not able to ping.

The output of, "ntpq -p" is,

     remote           refid      st t when poll reach   delay
offset  jitter
==============================================================================
 clock1.redhat.c .INIT.          16 u    -   64    0    0.000    0.000
4000.00
 clock2.redhat.c .INIT.          16 u    -   64    0    0.000    0.000
4000.00
 ns1.tuxfamily.n .INIT.          16 u    -   64    0    0.000    0.000
4000.00
 time.nist.gov   .INIT.          16 u    -   64    0    0.000    0.000
4000.00

By looking at the jitter, I know time is not getting synchronised, but
dont know why :(

Can you please tell me whether my ntp.conf file is correct ? What is
wrong here ? Do I need to always sync to NTP source with refid ==
INIT ?

Thanks.






More information about the questions mailing list