[ntp:questions] multicast - wrong interface

Danny Mayer mayer at ntp.isc.org
Sat Feb 17 03:43:18 UTC 2007


Martin wrote:
> Hello !
> 
> My NTP server sends all multicast traffic from eth0 and I don't
> know how to configure it to send it to the LAN connected via eth2.
> The details are below. Could you please give me some
> hints or help ?
> 

Right now you can't do it. I am aware of this issue. A related issue is
in Bug #725 though that's for IPv6. Part of the question is whether or
not there should be additional arguments to specify which interface to
broadcast on or whether to broadcast on all interfaces which is much
harder to do as there would need to be a lot of changes.

> Thank you
> 
> 	Martin
> 
> - - - - - -
> 
> In the ntp.conf there is:
> 	broadcast 224.0.1.1 key 145 ttl 3
> 
> and the linux kernel has a route for class D addresses, it uses eth2:
> 	Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
> 	224.0.0.0       *               240.0.0.0       U     0      0        0 eth2
> 
> but the output from ntp -D2 shows, that NTP has chosen eth0 (fd #18) and
> not eth2 (verified with tcpdump):
> 	created interface #2: fd=18, bfd=-1, name=eth0, flags=0x19, scope=0, 
> ifindex=0, sin=217.XX.XXX.XX, bcast=217.XX.XXX.223,, mask=255.255.255.224, 
> Enabled:
> 	......
> 	created interface #3: fd=19, bfd=-1, name=eth2, flags=0x19, scope=0, 
> ifindex=0, sin=192.168.XX.XX, bcast=192.168.XX.255,, mask=255.255.255.0, 
> Enabled:
> 	......
> 	MCAST   ***** sendpkt(fd=18 dst=224.0.1.1, src=217.XX.XXX.XX, ttl=96, len=68)
> 
> (BTW, why is ttl=96 and not 3 ? But that's not the problem.)
> 

That's a separate question and most likely a bug. I don't know why the
ttl is set to 96, there aren't that many hops in the world...

Please enter separate bug reports on these.

Thanks,
Danny



More information about the questions mailing list