[ntp:questions] Packet loss on peer associations?

mills at udel.edu mills at udel.edu
Thu Feb 22 20:35:05 UTC 2007


Jan,

It is normal that one or the other peers in symmetric modes appear to 
lose a packet. Not so; it might happen that the poll intervals don't 
completely match and one peer occasiionally transmits two packets while 
the other one transmits one. The protocol exchange is specially designed 
to detect what appear to be duplicate, missing or out of order packets.

If the poll intervals happen to be different, the protocol selects the 
minimum value of the two. If you leave things alone and the intervals 
finally climb to 1024 s while mismatching along the way, no harm is done.

Dave

Jan Ceuleers wrote:

> All,
> 
> I have recently started peering two of my NTP servers. One is a primary 
> server, the other only has Internet-based sources of synchronisation. 
> They are attached to the same LAN, which is lightly loaded, as are the 
> servers themselves (CPU usage rarely exceeds 1% and there is little disk 
> activity).
> 
> Quite often though, the association misses a beat (e.g. the reach number 
> reported by ntpq -p is 376 or another combination of mostly 1s and few 
> 0s). I would expect to see this in the presence of packet loss, but I 
> really don't think that that is the case here.
> 
> Note that I have clamped both maxpoll and minpoll to 6 on both sides 
> (because otherwise the problem was even worse, whenever the two peers 
> did not agree on the poll interval).
> 
> Is this a problem?
> 
> (One server is running ntpq 4.2.3p41 at 1.1401-o under Linux 2.4.20 on a 
> P4, the other ntpq 4.2.2p4 at 1.1585-o under Linux 2.4.31 on a soekris Geode).
> 
> Thanks, Jan




More information about the questions mailing list