[ntp:questions] disable pll not working?

Stifi stefanjuon at yahoo.com
Mon Jan 22 16:31:15 UTC 2007

Richard, according the manpage of xntpd:

           pll          enable     Enables the server to adjust  its
                                       local  clock.  If  not  set,
                                       local  clock  free-runs  at
                                       intrinsic   time   and
                                       offset. This flag  is  useful
                                       case  the  local  clock  is
                                       trolled by some other  device
                                       protocol  and NTP is used only
                                       provide synchronization to

...so disabling pll in the configuration of xntpd I would expect xntpd
no longer tries to set the time on the local system. Maybe I
misunderstand this option????

Richard B. Gilbert schrieb:

> Stifi wrote:
> > Hy there
> > I'm running a Zone on Solaris 10 which should provide xntpd services
> > for other servers. As I cannot set the system time in a zone I do so in
> > the globalzone using ntpdate.
> >
> If you can't set the time in a local zone, ntpd can't either!!
> Suggest you try running ntpd in the global zone.
> I don't understand what you are trying to do with disable pll, but see
> above!
> Also, you don't seem to have configured any internet servers or any
> hardware reference clock.
> If you are just trying to synchronize clocks with each other, suggest
> using rdate.  If you really care about the correct time, configure ntpd
> to get time from a source traceable to an atomic clock!

More information about the questions mailing list