[ntp:questions] disable pll not working?

Ronan Flood usenet at umbral.org.uk
Tue Jan 23 16:36:57 UTC 2007

"Stifi" <stefanjuon at yahoo.com> wrote:

> In my understanding it is basiclly the same, but ther seems to by a
> slight different. So is there a way to avoid xntpd setting the local
> time?

I thought that what I suggested before would do that, i.e.

 disable pll
 server prefer

That's how I read the code of xntpd3-5.93e, and seems to be the same in
OpenSolaris, see routine adj_host_clock() in


The "Can't adjust time" error comes from sys_adjtime() in ../libntp/systime.c,
which as I read it should not be called when the localclock is preferred.

If this suggestion does not work, as you say, than presumably something
more complicated is happening and I repeat what I said before: install
a later version and use "disable ntp".

Ronan Flood <usenet at umbral.org.uk>

More information about the questions mailing list