[ntp:questions] disable pll not working?

David L. Mills mills at udel.edu
Wed Jan 24 04:45:09 UTC 2007


Stifi,

Wrong. Check the xntpd source code. The manpage is wrong; I don't know 
where it came from; not from me.

You expose a prime example of why the authoritative NTPv4 source code 
and documentation come only from UDel; all other caches are not 
authoritative and in some cases have been modified in error. Who knows 
what other document errors are on those NTPv3 man pages.

Dave

Stifi wrote:

> Richard, according the manpage of xntpd:
> 
>            pll          enable     Enables the server to adjust  its
>                                        local  clock.  If  not  set,
> the
>                                        local  clock  free-runs  at
> its
>                                        intrinsic   time   and
> frequency
>                                        offset. This flag  is  useful
> in
>                                        case  the  local  clock  is
> con-
>                                        trolled by some other  device
> or
>                                        protocol  and NTP is used only
> to
>                                        provide synchronization to
> other
>                                        clients.
> 
> ...so disabling pll in the configuration of xntpd I would expect xntpd
> no longer tries to set the time on the local system. Maybe I
> misunderstand this option????
> 
> 
> 
> Richard B. Gilbert schrieb:
> 
> 
>>Stifi wrote:
>>
>>
>>>Hy there
>>>I'm running a Zone on Solaris 10 which should provide xntpd services
>>>for other servers. As I cannot set the system time in a zone I do so in
>>>the globalzone using ntpdate.
>>>
>>
>>If you can't set the time in a local zone, ntpd can't either!!
>>
>>Suggest you try running ntpd in the global zone.
>>
>>I don't understand what you are trying to do with disable pll, but see
>>above!
>>
>>Also, you don't seem to have configured any internet servers or any
>>hardware reference clock.
>>
>>If you are just trying to synchronize clocks with each other, suggest
>>using rdate.  If you really care about the correct time, configure ntpd
>>to get time from a source traceable to an atomic clock!
> 
> 




More information about the questions mailing list