[ntp:questions] disable pll not working?

Martin Burnicki martin.burnicki at meinberg.de
Thu Jan 25 08:33:17 UTC 2007


Stifi,

Stifi wrote:
> Hy there
> I'm running a Zone on Solaris 10 which should provide xntpd services
> for other servers. As I cannot set the system time in a zone I do so in
> the globalzone using ntpdate.
> 
> Here is the configuration (/etc/inet/ntp.conf):
> 
> # Fall back to local clock
> server 127.127.1.0
> fudge 127.127.1.0 stratum 9
> 
> # misc settings
> enable auth monitor
> disable pll
> driftfile /var/ntp/ntp.drift

> statsdir /var/ntp/ntpstats/
> filegen peerstats file peerstats type day enable file loopstats type
> day enable file clockstats type day enable

AFAIK ntpd v4 only tries to adjust the clock if a reference time source has
been configured which is not the local clock, and where it can pull time
from, or if it detects a driftfile with some value in it.

Since you have no other ref time source configured, ntpd is unable to pull
the time from some upstream source.

On the other hand you have configured a drift file, and if ntpd finds some
drift value in that file it "thinks" it is a drift value it has determined
before, and applies the corresponding drift compensation to the system
time.

Try to delete the drift file, and remove the "driftfile" entry from
ntp.conf. No "enable/disable pll" entry should be required.

I'm not sure whether this also applies to xntpd (v3).


Martin
-- 
Martin Burnicki

Meinberg Funkuhren
Bad Pyrmont
Germany




More information about the questions mailing list