[ntp:questions] New Windows NTP Installer available

gldickens3 gldickens3 at gmail.com
Fri Jul 27 12:02:44 UTC 2007


Hello Heiko,

I installed the new ntp version ntp-4.2.4p3 at 1.1502-foehr-o-win32-
setup.exe for Windows and it works great. Thanks!

I have been testing it on four Windows XP machines one of which is a
laptop.  The improvements over the earlier version 4.2.0a are
significant specifically because of the bug 622 fix.  I have
successfully tested this new version as follows:
- Service auto-start on boot up
- Disconnect/reconnect to network.
- Hibernate/awaken
- Standby/awaken

I do have three issues that I have discovered.

My first issue is the installation problem that you are already
discussing. I ended up just doing a complete uninstall/reinstall on
all of my machines which worked fine.

My second issue is that on the initial boot of my machines the ntpd
service successfully autostarts but it only includes one (1) ntp time
server even though I have seven (7)  time servers in my configuration
file. After which, if I restart the ntpd service then all seven of my
ntp time servers are included. I have rebooted several times and I
have been able to consistently reproduce this phenomena. Also, I had
previously been running version ntp-4.2.4p3-RC1 at foehr-o-win32-
setup.exe for a few days since you announced it on this forum.  With
that version, on initial boot the ntpd service only included three (3)
out of the seven (7) time servers in my configuration file. Likewise,
a restart of the ntpd service would then include all seven ntp time
servers.  I find this very strange.....

My third issue is minor. That is, the "ntpd --version" command does
not appear to work. The command hesitates for about 10 seconds and
then says: "Use -d, -q, --help or -n to run from the command line."
This happens regardless if the ntpd service is already running or
stopped.

Thanks again for this significant upgrade!

Gordon Dickens




More information about the questions mailing list