[ntp:questions] PPS problem on Fedora Core 6

Bogdan Rus bogdanrus2004 at yahoo.com
Fri Jul 27 19:12:48 UTC 2007


Hi,
  My name is Andrei Bogdan Rus and I am from Romania. I have a problem and I don't know how to solve it. Mabey you can help me.
  I am using a Trimble Palisade NTP Synchronization Sit. The computer used, runs Linux Fedora Core 6. When I configured the sistem to work with the gps receiver, everything worked fine. Now I am trying to make another computer running the same Linux distribution to sincronize with the NTP server and also to sincronize with the PPS pulse from the sinchronization kit.
  I took the kernel that Rodolfo Giometti offered at the address http://wiki.enneenne.com/index.php/LinuxPPS_support to support the PPS API. I also installed the tools ppstest and ppsctl  I found at  http://ftp.enneenne.com/pub/misc/linuxpps/test/,  My output when I run this tool is:
found PPS source #0 "serial0" on "/dev/ttyS0"
ok, found 1 source(s), now start fetching data...
source 0 - assert 1185518306.699172958, sequence: 10 - clear  1185516328.674035118, sequence: 9
source 0 - assert 1185518306.699172958, sequence: 10 - clear  1185518306.980946546, sequence: 10
source 0 - assert 1185518307.980928373, sequence: 11 - clear  1185518307.980907068, sequence: 11
source 0 - assert 1185518308.980868238, sequence: 12 - clear  1185518307.980907068, sequence: 11
source 0 - assert 1185518309.980829111, sequence: 13 - clear  1185518307.980907068, sequence: 11
source 0 - assert 1185518310.980810941, sequence: 14 - clear  1185518310.980789361, sequence: 12
  As I read, this should be the output if I receive the PPS signal corectly to the interface. So the PPS signal reaches to the serial interface and it is received corectly.
  I use NTP-4.2.2p4 with the refclock_atom patch downloaded from http://ftp.enneenne.com/pub/misc/linuxpps/refclocks/atom/
  The problem is that my NTPD is not sinchonising with the pps signal. The configuration file is:
  # /etc/ntp.conf, configuration for ntpd
driftfile /var/lib/ntp/ntp.drift
statsdir /var/log/ntpstats/
logfile /var/log/ntpd
  peer 193.226.6.168 prefer  #this is the server sinchronized with GPS Palisade kit
  ##########PPS##############
peer 127.127.22.0 prefer   # the pps signal is connected to the pin 1 (DCD)        from   my serial interface. I have only one serial interface
fudge 127.127.22.0 flag3 1
##########################
  As I read in the Driver22 tutorial from http://www.eecis.udel.edu/~mills/ntp/html/drivers/driver22.html i did in /dev, the link pps0
  The output from the command "ntpq -pn" is:
     remote           refid      st t when poll reach   delay   offset  jitter
==============================================================================
*193.226.6.168   .GPS.            1 u   41   64  377    0.234   24.256   9.756
 127.127.22.0    .PPS.            0 l    -   64    0    0.000    0.000   0.001
 
and from the command "ntpq -c as" is:
ind assID status  conf reach auth condition  last_event cnt
===========================================================
  1 10546  9634   yes   yes  none  sys.peer   reachable  3
  2 10547  8035   yes   yes  none    reject  clock expt  3
  So, as you see, the sistem is not sinchonising with the PPS signal. I don't know what is the reason.
  I think that NTPD receives the signal, because in the log is written that refclock: found PPS source.... These are the /var/log/ntpd contents:
  27 Jul 16:25:13 ntpd[15941]: refclock: found PPS source #0 "/dev/ttyS0" on "serial0"
27 Jul 16:25:13 ntpd[15941]: refclock_atom: time_pps_kcbind failed: Operation not supported
27 Jul 16:29:31 ntpd[15941]: synchronized to 193.226.6.168, stratum 1
27 Jul 16:29:34 ntpd[15941]: time reset +2.385646 s
27 Jul 16:29:34 ntpd[15941]: kernel time sync enabled 0001
27 Jul 16:32:55 ntpd[15941]: synchronized to 193.226.6.168, stratum 1
  I found that other people had the log almost the same, but after sinchronising with the peer, there is another log message "synchonized to PPS(0), stratum 0", but I never get this message and is never synchronising.
  I want to mention that the GPS receiver, receives signal from the satellites.
  Thank you for your time, Have a god day



 
   ____________________________
  |                            |
  |  ing.  Andrei Bogdan RUS   |
  |                            |
  |    Tel. +40-744-267970     |
  |____________________________|
   
   

       
---------------------------------
Choose the right car based on your needs.  Check out Yahoo! Autos new Car Finder tool.


More information about the questions mailing list