[ntp:questions] Time steping regardless of "-x" slew only option

David L. Mills mills at udel.edu
Sat Jun 23 23:50:33 UTC 2007


Guyus,

I assume you are using the documentation that came with the NTP version 
you use. If NTPv3 (xntpd) some very broken things were in that version. 
In ntpd (NTPv4) the -x otion is still there, but has a slightly 
different interpretation. It sets the step threshold from the default 
128 ms to 600 s. The step threshold can be set to other values with the 
tinker step command.

The xntpd and early ntpd used a different feedback loop for ordinary and 
slew modes. The later ntpd uses a single loop, but steps only if the 
offset exceeds the step threshold.

You might see a slightly differentr behavios ir the recommended kernel 
design is implemented. In this design a step forward is implemented 
directly, but a step backward up to one second causes the system clock 
to stop for one second or increment slowly during that second. A step 
backward more than one second is implemented directly.

As you might expect, the reason for this behavior is to handle leap 
seconds gracefully.

Dave

Richard B. Gilbert wrote:
> vwvr6vw wrote:
> 
>> I am using AIX 5.4 and NTP version 3.4 from what I can tell, which
>> came with the operating system.  ntpq, "v" option returns 3.4y.
>>
>> This is not a startup condition.  xntpd has been running for a while
>> before the steps.
>>
>> I realize that I have other issues causing the need for steps.  I am
>> investigating this problem as well.  I only have one time server, so I
>> have network issues or something that is causing the need for the
>> steps.  Underneath the one server, we have several of our processors
>> acting as servers to the rest of our system.  If one of our servers is
>> having interrupt delays from disk activity or some other issue,
>> perhaps that is causing the dicrepency.  Does anyone know the best way
>> to debug such a situation?
>>
>> But I still need to understand why NTP is stepping when the
>> documentation I have says that it should not with the "-x" option.  We
>> have a distributed processing system with many processors.  It is
>> imperative that time does not step on any of our processors or our
>> software will detect heartbeat problems.  That is what is currently
>> happening, so I know that real steps are occuring and not just steps
>> in the ntp.log file.
>>
>>
>>
> 
> Can you show us the output of "ntpq -p"?
> 
> It would also be helpful to see the contents of your ntp.conf.  Please 
> omit the comments unless they are necessary for us to understand what 
> your are doing.
> 
> The current version of ntpd (the "x" was dropped many years ago) is 
> V4.2.x.  I think "x" was equal to 4 the last time I looked.  V3.4 is 
> ancient!  Is it possible for you to upgrade to something a few years 
> more recent?
> 
> Are the steps always in the same direction?  That is are they all 
> positive, or all negative?  All steps in the positive direction would 
> tend to suggest that something is masking or disabling clock interrupts 
> for a much longer time than it should.  This problem is known to occur 
> with some versions of Windows and Linux.  I have not heard of such a 
> problem with AIX. . . .
> 
> As to why nptd is stepping, I can only guess.  If the local clock is in 
> error by a significant amount, it could take ntpd a very long time to 
> correct by slewing the clock.  The maximum slew  rate is 500 PPM or 
> about 43 seconds per day.
> 




More information about the questions mailing list