[ntp:questions] NTP Sync Problem

Ron C. nospam at nospam.com
Thu Mar 8 10:23:18 UTC 2007

"Ryan Malayter" <malayter at gmail.com> wrote in message news:1173281502.368065.80960 at p10g2000cwp.googlegroups.com...

> Have you tried using us.pool.ntp.org servers instead? What about
> ntp.level3.net? (Covad appears to use Level 3 for backbone transit). I
> can't imagine Covad is blocking all UDP port 123 traffic, unless
> they're trying to stop P2P clients from using that.

Thanks for the suggestion.  I tried them also but the problem is the same.  However I did manage to get a semi-understandable explanation from Covad as to what is going on.  It has to do with the type of service I have (multiple routable IP addresses as opposed to a single IP using NAT).  Apparently T1 and DSL routers have 2 IPs: The WAN IP and the LAN IP.  The LAN IP is like another routable host on my network.  However Covad makes the WAN IP private (non-routable) with the local end programmed as and the remote as  Apparently Netopia uses the WAN IP for  NTP  and the router knows that it makes no sense to try to use NTP with a non-routable IP, so it logs the "cannot send" error message.

Of course, this bring to mind even more questions like 1) Why do routers need 2 IPs?  2) Why doesn't Netopia use the routable LAN IP for  NTP or a least let you specify which one to use?  3) Why can't I donate one of my routable network IPs for use as the WAN IP?  4) Do all the routers it the world, providing the same type of service, have this inablity to use NTP?  5) How common is it for router clocks to drift by 8 minutes per day (as both of mine do).

More information about the questions mailing list