[ntp:questions] NTP Sync Problem

Per Hedeland per at hedeland.org
Thu Mar 8 23:48:42 UTC 2007


In article <33448$45efe4e1$42865632$32620 at msgid.meganewsservers.com>
"Ron C." <nospam at nospam.com> writes:
>
>Thanks for the suggestion.  I tried them also but the problem is the
>same.  However I did manage to get a semi-understandable explanation
>from Covad as to what is going on.  It has to do with the type of
>service I have (multiple routable IP addresses as opposed to a single IP
>using NAT).  Apparently T1 and DSL routers have 2 IPs: The WAN IP and
>the LAN IP.  The LAN IP is like another routable host on my network. 
>However Covad makes the WAN IP private (non-routable) with the local end
>programmed as 0.0.0.0 and the remote as 127.0.0.2.  Apparently Netopia
>uses the WAN IP for  NTP  and the router knows that it makes no sense to
>try to use NTP with a non-routable IP, so it logs the "cannot send"
>error message.

I'm not sure I followed all that, but if the router has its WAN
interface "configured" with 0.0.0.0, it's no surprise that it refuses to
originate traffic in that direction. Nothing NTP-specific, nor even
necessarily knowledge about what is "routable", but sending out IP
packets with source address 0.0.0.0 is just Plain Wrong (unless you're
booting and need to speak DHCP/BOOTP before you can get your address).

But I believe you said that it worked fine to do NTP requests from
inside your network (and I would expect that, as long as the router
doesn't try to NAT them to 0.0.0.0:-). Couldn't you just set up an NTP
server there, and point the router at *that*? This would also have the
advantage that if the router goes berserk and starts spewing requests
continously, only you will suffer.:-)

--Per Hedeland
per at hedeland.org




More information about the questions mailing list