[ntp:questions] leap_second,

Martin Burnicki martin.burnicki at meinberg.de
Fri Mar 23 08:28:09 UTC 2007


Robert Sebestyen wrote:
> Hi,
> some weeks ago i got an excellent support from the community.
> I was able to make my server run.
> Now i am struggeling with a special problem and i have no idea how to do!?
> For official timeservers you have to add on certain days one second more.
> Brief:
> For example:
> On December 31st on midnight you have to give 23:59:59.
> The server is synchroniced to a HP5071A. If you try to solve the problem
> with date -s '12/31/year 23:59:59' ntpd-service is showing a offset to
> other servers of 2seconds instead 1second! Has anybody a idea how to solve
> the problem or did somebody already faced that problem being able to solve
> it! Operating system in use is Redhat-Linux, ntpd is synchroniced as said
> to a HP-5071A. Greetings Robert

For a short introduction you might have a look at 
"Leap Seconds and how they are handled by Meinberg Devices and NTP"

It is very important for NTP that the leap second is announce before it is
inserted, otherwise it would handle the leap second as a normal time step.

If the HP5071A is unable to pass a leap second announcement to the NTP
daemon then the NIST leap second file may help:
See the section: "Using the NIST Leap Second File" at

Please note that autokey must be enabled for the server to handle the leap
second file, and the file will have to be updated once the next leap second
has been announced by the IERS, see

Martin Burnicki

Meinberg Funkuhren
Bad Pyrmont

More information about the questions mailing list