[ntp:questions] Embedded Linux NTP system -500 drift

Richard B. gilbert rgilbert88 at comcast.net
Thu Mar 29 15:13:01 UTC 2007


Cliff wrote:
> Thanks for the pointers. I will withold mentioning the device
> manufacturer for the time being as technical support has been helpful
> and they have reproduced the problem but they still have no idea what
> is wrong. Further, I have completely reproduced this issue on an
> identical but separate device. I am now using a single stratum 1
> server, 64.236.96.53 to eliminate as many variables as possible.
> 
> The device does not include debugging utilities such as ntpq or
> ntptrace so it makes it a little more difficult to test (I have
> actually suggested that these commands get included in their firmware
> update).
> 
> Here is the ntp.drift file when ssh into the firewall:
> 
> Sash command shell (version 1.1.1)
> /> cat /etc/config/ntp.drift
> -500.000
> />
> 
> Here is 'ntpq -pn' from an external client to the firewall NTP server
> (after recent restart, so poll is low):
> 
> remote		refid		st t	when	poll	reach	delay	offset	jitter
> ==============================================================================
> *66.229.xxx.xxx	64.236.96.53	2  u	34	64	377	41.939	-2.830	2.130
>  127.127.1.0	LOCAL(0)	10 l	27	64	377	0.000	0.000	0.001
> 
> Here is 'ntptrace' from external client to the firewall:
> 
> localhost: stratum 3, offset -0.005504, synch distance 0.063529
> c-66-229-xxx-xxx.hsd1.fl.comcast.net: stratum 2, offset -0.023189,
> synch distance 0.035368
> 64.236.96.53: stratum 1, offset 0.000000, synch distance 0.002650,
> refid 'ACTS'
> 
> I'd appreciate any further assistance. Harlan mentions an HZ problem.
> Not sure what that is. Is that Hz as in Hertz?
> 
> Thanks!
> 

"HZ" is a Linux Kernel parameter that can be set to values such as 100, 
250 or 1000.  It controls the rate at which the clock is updated.  If HZ 
is set to values greater than 100 it is possible for Linux to lose clock 
interrupts if something masks or disables interrupts for too long a 
time.  I don't know if this is a consideration in embedded Linux or not. 
  If ntpd is having problems staying synchronized and HZ is greater than 
100, try setting it to 100.




More information about the questions mailing list