[ntp:questions] ntpd -g problem (4.2.4p0).

Richard B. gilbert rgilbert88 at comcast.net
Fri Mar 30 00:43:24 UTC 2007

Kaz Kylheku wrote:
> I'm trying to set up ntpd on an embedded Linux system (glibc 2.5,
> kernel 64 bit MIPS kernel, n32 user space). I've built
> everything from scratch.
> How do I get ntpd to step the initial clock? ``ntpd -q -g'' does work,
> as does ntpdate.
> But I just want ntpd to step the time, and then stay running. Is that
> possible?
> I've tried it under various offset conditions. I set the time so that
> it was only 200 seconds off; I set it so it was just over 1000 seconds
> off; and I set it so it was years off. Under none of those conditions
> does ntpd -g do anything. It stays running, and the clock stays wrong.

ntpd -g is supposed to set the clock to the correct time and keep on 
running.  If it does not do so on your system we will need details in 
order to troubleshoot the problem.

The clock must be within 34 years of the correct time in order for ntpd 
to work properly.  I'd suggest setting the clock to at least the correct 
year before starting ntpd.

Ntpd needs to be able to access its upstream servers in order to do 
anything useful.  This means your tcp/ip stack must be initialized 
before you start ntpd.

More information about the questions mailing list