[ntp:questions] ntpd -g problem (4.2.4p0).

Per Hedeland per at hedeland.org
Fri Mar 30 07:16:03 UTC 2007


In article <460C5D2C.5000002 at comcast.net> "Richard B. gilbert"
<rgilbert88 at comcast.net> writes:
>Kaz Kylheku wrote:
>> I'm trying to set up ntpd on an embedded Linux system (glibc 2.5,
>> kernel 2.6.17.7. 64 bit MIPS kernel, n32 user space). I've built
>> everything from scratch.
>> 
>> How do I get ntpd to step the initial clock? ``ntpd -q -g'' does work,
>> as does ntpdate.
>> 
>> But I just want ntpd to step the time, and then stay running. Is that
>> possible?
>> 
>> I've tried it under various offset conditions. I set the time so that
>> it was only 200 seconds off; I set it so it was just over 1000 seconds
>> off; and I set it so it was years off. Under none of those conditions
>> does ntpd -g do anything. It stays running, and the clock stays wrong.
>> 
>
>ntpd -g is supposed to set the clock to the correct time and keep on 
>running.  If it does not do so on your system we will need details in 
>order to troubleshoot the problem.
>
>The clock must be within 34 years of the correct time in order for ntpd 
>to work properly.  I'd suggest setting the clock to at least the correct 
>year before starting ntpd.

Actually no, as I reported just the other day, it's enough to be within
+/- 68 years for 4.2.4p0 (and probably some earlier versions after
4.2.0, I haven't checked where the fix was done). I doubt this is
related to the OP's problem, but 'ntpd -g' worked just fine with 4.2.4p0
and the date originally set to Jan 1, 1940.

--Per Hedeland
per at hedeland.org




More information about the questions mailing list