[ntp:questions] NTP not syncing

Steve Kostecke kostecke at ntp.isc.org
Sat May 5 23:41:17 UTC 2007


On 2007-05-05, Richard B. Gilbert <rgilbert88 at comcast.net> wrote:

> Michael wrote:
>
>> I am running ntp 4.2.4
>>
>> My server statement is server ntpserver01 iburst burst maxpoll 7
>>
>> Anybody got any clues as to why they dont sync or how to fix it or
>> even debug why NTP does not seem to like the server.
>
> Start by removing the "burst" and "maxpoll 7" from your server
> statements!
>
> Start ntpd with the "-g" option.

That's good advice but it has nothing to do with the real problem.

As has been mentioned elsewhere, this is most likely a restriction
problem. Certain OSes include a 'restrict default ignore' line in the
ntp.conf installed by their pre-packaged versions of NTP.

> Wait at least thirty minutes and issue: ntpq -p

It is hardly necessary to wait 30 minutes for the ntpq peer status
billboard to show whether or not ntpd is able to communicate with its
remote time servers.

-- 
Steve Kostecke <kostecke at ntp.isc.org>
NTP Public Services Project - http://ntp.isc.org/




More information about the questions mailing list