[ntp:questions] Problem with xntp after reinstall on openSUSE 10.3

Richard B. Gilbert rgilbert88 at comcast.net
Mon Oct 15 16:54:32 UTC 2007


Marc Muehlfeld wrote:
> Hello,
> 
> I run a xntp server on Suse 10.0 for the last 2 years. Last week I 
> reinstalled the server using openSUSE 10.3. I setup the server to run 
> chroot (in /etc/sysconfig/ntp) like before and use the same ntp.conf. 
> But now the time is allways wrong after some hours.
> 
> Meanwhile I took all restrict rules out of the file (but I had them in 
> before too and it worked for a long time), but still have this problem. 
> This is the current ntp.conf I use:
> 
> 
> server 127.127.1.0              # Local clock
> fudge  127.127.1.0 stratum 10   # Local clock is unsynchronized (stratum 
> 10)
> 
> server 0.de.pool.ntp.org        iburst prefer
> server 1.de.pool.ntp.org        iburst
> server 2.de.pool.ntp.org        iburst
> 
> driftfile /var/lib/ntp/drift/ntp.drift
> logfile   /var/log/ntp
> 
> 
> About two minutes after starting xntpd:
> # ntpq -p
>      remote           refid      st t when poll reach   delay   offset  
> jitter
> ============================================================================== 
> 
>  LOCAL(0)        .LOCL.          10 l   21   64    1    0.000    0.000   
> 3.906
> *213.ip-net02.em 192.53.103.108   2 u    4   64    1   16.846  113.006  
> 48.404
> +www.alter-provi 217.91.44.17     2 u    3   64    1   27.271  147.323  
> 39.202
> +berlin.zq1.de   194.25.115.122   2 u    2   64    1   28.322  121.759  
> 46.183
> 
> 
> About 5 minutes after startup it fall back to local and ntpd shows:
> # ntpq -p
>      remote           refid      st t when poll reach   delay   offset  
> jitter
> ============================================================================== 
> 
> *LOCAL(0)        .LOCL.          10 l   17   64   37    0.000    0.000   
> 3.906
>  213.ip-net02.em 192.53.103.108   2 u   16   64   37   16.435  1247.22 
> 958.049
>  www.alter-provi 217.91.44.17     2 u   14   64   37   28.379  1298.52 
> 968.629
>  berlin.zq1.de   194.25.115.122   2 u   12   64   37   27.911  1269.07 
> 973.514
> 
> 
> The ntp logfile just says:
> # cat /var/log/ntp
> 15 Oct 17:31:09 ntpd[6534]: synchronized to 62.52.175.213, stratum 2
> 15 Oct 17:31:09 ntpd[6534]: kernel time sync status change 0001
> 15 Oct 17:35:11 ntpd[6534]: synchronized to 85.25.132.119, stratum 2
> 15 Oct 17:35:15 ntpd[6534]: synchronized to LOCAL(0), stratum 10
> 
> 
> After 2 days my ntp server has allready a delay to the real time of 
> about 20 minutes. Any idea why it allways fall back to local? The 
> internet connection is allways available.
> 
> 
> Regards
> Marc

My first guess would be that your local clock is off by more than 500 
Parts Per Million (PPM).  500 PPM is the maximum frequency correction 
that ntpd can make.  If the local clock is worse than that your options 
are to:
a. Live with it.
b. Get it fixed or adjust it (adjtimex???)

If you have a drift file, check the value stored in it.  Most machines 
will have an absolute value less than 50.  If the absolute value is 
substantially greater than 100 you may have a problem with the local 
clock.  Ntpd is supposed to be able to cope but I've not yet seen a 
local clock that's off by more than 100 PPM.


Some Linux (and Windows) systems have been found to "lose" clock 
interrupts.  The usual symptom is that ntpd "steps" the clock quite often.




More information about the questions mailing list