[ntp:questions] false cru .libs/libopts.a libopts_la-libopts.o

Szallár Zsolt szallar at fszek.hu
Tue Oct 30 14:15:17 UTC 2007


Hello,

I tried to compile the ntp-4.2.4p4 on my sparc-sun-solaris2.9, but I got 
error message
What can I do?
I post the end of the make output:

In file included from libopts.c:28:
tokenize.c: In function `copy_cooked':
tokenize.c:51: warning: cast discards qualifiers from pointer target type
/bin/bash ../libtool --tag=CC --mode=link gcc  -g -O2 
-D_LARGEFILE64_SOURCE -Wall -Wcast-qual -Wmissing-prototypes 
-Wpointer-arith -Wshadow -Wstrict-prototypes   -o libopts.la  
-version-info  29:0:4 libopts_la-libopts.lo  -lkvm -lelf -lxnet -lsocket 
-lrt -lmd5 -lnsl -lgen
mkdir .libs
libtool: link: warning: `-version-info/-version-number' is ignored for 
convenience libraries
false cru .libs/libopts.a  libopts_la-libopts.o
make[2]: *** [libopts.la] Error 1
make[2]: Leaving directory `/opt/ntp-4.2.4p4/libopts'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/opt/ntp-4.2.4p4'
make: *** [all] Error 2

tnx

szor




More information about the questions mailing list