[ntp:questions] ACTS Problem with Internal Modem

taro.johnson at gmail.com taro.johnson at gmail.com
Sat Jun 7 21:47:27 UTC 2008


Sorry for the delay in getting back but I've been very busy lately.
Thanks for the replies but I've tried using the debug mode to see what
was going on and I still can't tell why its not working under ntpd's
control. I've tried this in both FreeBSD 6.2 & 7.0 with 2 different
3com modem, both however the same modem.

Here are the lines produced concerning the modem when pciconf -l -v is
executed.

sio4 at pci0:3:3:0:        class=0x070002 card=0x00d312b9 chip=0x100812b9
rev=0x01 hdr=0x00
    vendor     = '3COM Corp, Modem Division (Formerly US Robotics)'
    device     = 'USR5610B USR5610B (0005610-02) 56K Performance Pro
Modem (PCI Internal)'
    class      = simple comms
    subclass   = UART

When I run ntpd -ddd here is what I get. (I've modified the IP
addresses within the log to keep it a bit more anonymous.)

ntpd 4.2.4p5-RC1 at 1.1531-o Sat Jun  7 20:40:01 UTC 2008 (1)
addto_syslog: set_process_priority: Leave priority alone:
priority_done is <2>
addto_syslog: precision = 1.955 usec
create_sockets(123)
addto_syslog: ntp_io: estimated max descriptors: 7322, initial socket
boundary: 20
addto_syslog: Listening on interface #0 wildcard, 0.0.0.0#123 Disabled
update_interfaces(123)
addto_syslog: no IPv6 interfaces found
addto_syslog: no IPv6 interfaces found
create_interface(192.168.161.104#123)
addto_syslog: Listening on interface #1 em0, 192.168.161.104#123
Enabled
created interface #1: fd=21, bfd=-1, name=em0, flags=0x19, scope=0,
ifindex=0, sin=192.168.161.104, bcast=192.168.161.255,,
mask=255.255.255.0, Enabled:
updating interface #1: fd=21, bfd=-1, name=em0, flags=0x19, scope=0,
ifindex=0, sin=192.168.161.104, bcast=192.168.161.255,,
mask=255.255.255.0, Enabled: new - created
create_interface(192.167.113.32#123)
addto_syslog: Listening on interface #2 em1, 192.167.113.32#123
Enabled
created interface #2: fd=22, bfd=-1, name=em1, flags=0x19, scope=0,
ifindex=0, sin=192.167.113.32, bcast=192.167.113.255,,
mask=255.255.255.0, Enabled:
updating interface #2: fd=22, bfd=-1, name=em1, flags=0x19, scope=0,
ifindex=0, sin=192.167.113.32, bcast=192.167.113.255,,
mask=255.255.255.0, Enabled: new - created
create_interface(127.0.0.1#123)
addto_syslog: Listening on interface #3 lo0, 127.0.0.1#123 Enabled
created interface #3: fd=23, bfd=-1, name=lo0, flags=0x15, scope=0,
ifindex=0, sin=127.0.0.1, mask=255.0.0.0, Enabled:
updating interface #3: fd=23, bfd=-1, name=lo0, flags=0x15, scope=0,
ifindex=0, sin=127.0.0.1, mask=255.0.0.0, Enabled: new - created
create_sockets: Total interfaces = 4
addto_syslog: Listening on routing socket on fd #24 for interface
updates
init_io: maxactivefd 24
local_clock: time 0 offset 0.000000 freq 0.000 state 0
addto_syslog: kernel time sync status 2040
getnetnum given 127.127.18.1, got 127.127.18.1 (t_UNK/0)
newpeer: cast flags: 0x1 for address: 127.127.18.1
newpeer: using fd 23 and our addr 127.0.0.1
peer_crypto_clear: at 0 next 0 assoc ID 60972
key_expire: at 0
peer_clear: at 0 next 1 assoc ID 60972 refid INIT
newpeer: 127.0.0.1->127.127.18.1 mode 3 vers 4 poll 11 15 flags 0x21
0x1 ttl 0 key 00000000
getnetnum given 127.127.18.1, got 127.127.18.1 (t_REF/1)
addto_syslog: frequency initialized 0.000 PPM from /var/ntp/ntp.drift
authtrust: keyid 0000ffff life 1
local_clock: time 0 offset 0.000000 freq 0.000 state 1
report_event: system event 'event_restart' (0x01) status 'sync_alarm,
sync_unspec, 1 event, event_unspec' (0xc010)
refclock_setup fd 4 modem status: 0x127
refclock_ioctl: fd 4 flags 0xa4
acts: setup ATB1&C0&D2E0L1M1Q0V1
refclock_transmit: at 1 127.127.18.1
poll_update: at 1 127.127.18.1 flags 0021 poll 11 burst 0 last 1 next
2051
auth_agekeys: at 1 keys 1 expired 0
timer: refresh ts 0
timer: interface update
update_interfaces(123)
addto_syslog: no IPv6 interfaces found

addto_syslog: no IPv6 interfaces found

refclock_gtraw: fd 4 time 3421861508.760820 timecode 1 Q
refclock_gtraw: fd 4 time 3421861508.769643 timecode 4 0V1
addto_syslog: acts: no modem

refclock_gtraw: fd 4 time 3421861511.761957 timecode 2 AT
refclock_gtraw: fd 4 time 3421861511.770210 timecode 8 H OK

acts: 0125 (6 3) 7 Q0V1ATH
acts: 0125 (6 3) 2 OK
refclock_setup fd 4 modem status: 0x127
refclock_ioctl: fd 4 flags 0xa4
acts: setup ATB1&C0&D2E0L1M1Q0V1
refclock_gtraw: fd 4 time 3421861517.760812 timecode 1 Q
refclock_gtraw: fd 4 time 3421861517.769699 timecode 4 0V1
addto_syslog: acts: no modem

refclock_gtraw: fd 4 time 3421861520.762703 timecode 3 ATH
refclock_gtraw: fd 4 time 3421861520.769703 timecode 6  OK
acts: 0125 (6 3) 7 Q0V1ATH
refclock_gtraw: fd 4 time 3421861520.772693 timecode 1

acts: 0125 (6 3) 2 OK
refclock_setup fd 4 modem status: 0x127
refclock_ioctl: fd 4 flags 0xa4
acts: setup ATB1&C0&D2E0L1M1Q0V1
refclock_gtraw: fd 4 time 3421861526.760847 timecode 1 Q
refclock_gtraw: fd 4 time 3421861526.762709 timecode 2 0V
refclock_gtraw: fd 4 time 3421861526.769710 timecode 2 1
addto_syslog: ntpd exiting on signal 2


I know the modem is working just fine as I'm able to do the following
at a simple terminal

ntp# tip com5
connected
AT
OK
ATI
5601

OK
ATB1&C0&D2E0L1M1Q0V1
OK
   <--THERE WAS AN ATZ ISSUED HERE
OK
ATB1&C0&D2L3M1Q0V1  <-- SAME SETUP STRING MINUS THE E0 AS I WANTED TO
SEE THE STRING
OK
ATDT9,13034944774
CONNECT 14400/ARQ/V32/LAPM/V42BIS

National Institute of Standards and Technology
Telephone Time Service, Generator 1b
Enter the question mark character for HELP
                        D  L
 MJD  YR MO DA HH MM SS ST S UT1 msADV         <OTM>

54624 08-06-07 21:17:24 50 0 -.4 045.0 UTC(NIST) *
54624 08-06-07 21:17:25 50 0 -.4 045.0 UTC(NIST) *
54624 08-06-07 21:17:26 50 0 -.4 045.0 UTC(NIST) *
54624 08-06-07 21:17:27 50 0 -.4 045.0 UTC(NIST) *
54624 08-06-07 21:17:28 50 0 -.4 045.0 UTC(NIST) *
54624 08-06-07 21:17:29 50 0 -.4 045.0 UTC(NIST) *
54624 08-06-07 21:17:30 50 0 -.4 045.0 UTC(NIST) *

Any more assistance is greatly appreciated.




More information about the questions mailing list