[ntp:questions] chu and wwv audio driver problems in debian lenny

jimmyterrence at gmail.com jimmyterrence at gmail.com
Mon Nov 24 18:19:25 UTC 2008


I've been trying for the past couple of weeks to set up an ntp server
syncing with chu using the audio drivers.  I got sound set up on the
computer that I'm using (an old dell GX110) using the open sound
drivers from http://www.opensound.com/

I have a Kaito KA1103 that I tuned to CHU on 3330 kHz. I ran the audio
signal out of the radio from the line out port, through an audio
isolation transformer into the line in port on the Dell.  When I plug
a set of headphones into the line out port on the computer, I can hear
the audio clearly.  However, ntp never seems to sync using the audio
signal.

I changed to WWV audio drivers and set the radio to listen to WWV at
10 MHz to see if I could get it to sync to that, and it doesn't.

I'm using the stock kernel in lenny with the stock install of ntp from
apt-get.  Below are my config files and settings:

If there are any other settings that you want to see, please let me
know.

/etc/ntp.conf

# /etc/ntp.conf, configuration for ntpd; see ntp.conf(5) for help

driftfile /var/lib/ntp/ntp.drift

# Enable this if you want statistics to be logged.
statsdir /var/log/ntpstats/

statistics loopstats peerstats clockstats
filegen loopstats file loopstats type day enable
filegen peerstats file peerstats type day enable
filegen clockstats file clockstats type day enable

#server 127.127.7.0
#fudge 127.127.7.0 flag2 1 flag4 1 time1 0.0005366 stratum 1
server 127.127.36.0 version 4
fudge 127.127.36.0 time1 0.007532 flag2 1 stratum 1

# Local users may interrogate the ntp server more closely.
restrict 127.0.0.1
restrict ::1

# Clients from this (example!) subnet have unlimited access, but only
if
# cryptographically authenticated.
#restrict 192.168.123.0 mask 255.255.255.0 notrust

/etc/ntp.audio0

idev /dev/dsp
cdev /dev/mixer
source line
agc line
monitor line

ntpq -c cl

assID=0 status=0101 clk_noreply, last_clk_noreply,
device="WWV/H Audio Demodulator/Decoder", timecode=, poll=197,
noreply=197, badformat=0, baddata=0, fudgetime1=7.532, stratum=1,
refid=, flags=2

ntpdc -c kerninfo

pll offset:           0 s
pll frequency:        0.000 ppm
maximum error:        6.35652 s
estimated error:      1.6e-05 s
status:               0040  unsync
pll time constant:    4
precision:            1e-06 s
frequency tolerance:  500 ppm

ntpdc -c loopinfo

offset:               0.000000 s
frequency:            0.000 ppm
poll adjust:          0
watchdog timer:       12743 s

aumix -q (mixer settings)

vol 72, 72, P
pcm 92, 92
speaker 0, 0
line 84, 84, P
mic 96, 96, R
cd 0, 0, P
igain 75, 75
line1 4, 4, P
phin 0, 0, P
phout 75, 75, P
video 0, 0, P
monitor 0, 0

There are no entries in /var/log/ntpstats

/var/log/syslog, when I restart ntp

Nov 24 07:58:21 time ntpd[2195]: ntpd exiting on signal 15
Nov 24 07:58:24 time ntpd[2487]: ntpd 4.2.4p4 at 1.1520-o Wed Jul 16
12:11:41 UTC 2008 (1)
Nov 24 07:58:24 time ntpd[2488]: precision = 1.000 usec
Nov 24 07:58:24 time ntpd[2488]: Listening on interface #0 wildcard,
0.0.0.0#123 Disabled
Nov 24 07:58:24 time ntpd[2488]: Listening on interface #1
wildcard, ::#123 Disabled
Nov 24 07:58:24 time ntpd[2488]: Listening on interface #2 lo, ::1#123
Enabled
Nov 24 07:58:24 time ntpd[2488]: Listening on interface #3 lo,
127.0.0.1#123 Enabled
Nov 24 07:58:24 time ntpd[2488]: kernel time sync status 0040
Nov 24 07:58:24 time ntpd[2488]: frequency initialized 0.000 PPM from /
var/lib/ntp/ntp.drift

Thank you,

Court




More information about the questions mailing list