[ntp:questions] chu and wwv audio driver problems in debian lenny

Steve Kostecke kostecke at ntp.org
Tue Nov 25 22:44:59 UTC 2008


On 2008-11-25, jimmyterrence at gmail.com <jimmyterrence at gmail.com> wrote:

> I downloaded the source from http://www.ntp.org/downloads.html before
> I saw your post on how to do it by building a deb package.  I can redo
> it that way if it will work better, though.

If all you are doing is using this ntpd for testing I would not worry
too much.

The key advantage to leveraging the package management system is that it
will take care of satisfying all of the build-depends for you (with the
'apt-get build-dep ntp' command) and gives you a fully integrated
package.

[snip]

> getnetnum given 127.127.7.0, got 127.127.7.0 (t_UNK/0)
> newpeer: cast flags: 0x1 for address: 127.127.7.0
> newpeer: using fd 20 and our addr 127.0.0.1
> peer_crypto_clear: at 0 next 0 assoc ID 2307
> peer_clear: at 0 next 1 assoc ID 2307 refid INIT
> audio_config_read: reading </etc/ntp.audio0>
> idev </dev/oss/ich0/pcm0>
> cdev </dev/oss/ich0/mix0>
> agc <line> 8
> monitor <line> 6
> audio_init: </dev/oss/ich0/pcm0> bufsiz 240
> audio_show: ctl_fd 6
> newpeer: 127.0.0.1->127.127.7.0 mode 3 vers 4 poll 6 10 flags 0x1021
> 0x1 ttl 0 key 00000000
> getnetnum given 127.127.7.0, got 127.127.7.0 (t_REF/1)
> authtrust: keyid 0000ffff life 1
> local_clock: time 0 offset 0.000000 freq 0.000 state 1
> report_event: system event 'event_restart' (0x01) status 'sync_alarm,
> sync_unspec, 1 event, event_unspec' (0xc010)
> refclock_transmit: at 1 127.127.7.0
> poll_update: at 1 127.127.7.0 flags 1021 poll 6 burst 0 last 1 next 65
> auth_agekeys: at 1 keys 1 expired 0
> timer: interface update
> update_interfaces(123)
> auth_agekeys: at 60 keys 1 expired 0
> refclock_transmit: at 65 127.127.7.0
> poll_update: at 65 127.127.7.0 flags 1021 poll 6 burst 0 last 65 next 128

It appears as though ntpd is properly recognizing and setting up the CHU
ref-clock.

It is possible that you are telling ntpd to monitor the correct sound
line.

> I'm guessing the
>
>  auth_agekeys: at 720 keys 1 expired 0
>
> lines means that ntp isn't hearing the audio signal, for whatever
> reason.

That line is entirely unrelated to your problem.

> While I was writing this post, something else came up in the debug
> output:

[snip]

> Is this significant?

No.

-- 
Steve Kostecke <kostecke at ntp.org>
NTP Public Services Project - http://support.ntp.org/




More information about the questions mailing list