[ntp:questions] QoS always the same Freebsd 6.1 ntpd 4.2.5p135 at 1.1793-o

Rob Neal hundoj at comcast.net
Mon Oct 6 02:11:10 UTC 2008

On Sun, 5 Oct 2008, Hans Jørgen Jakobsen wrote:

> I would like NTP traffic to use my providers EF traffic class. One way of
> doing that would be to send packet with DSCP == 46 (TOS byte == 184).
> But I have had no luck.
> I have fetched latest dev version (4.2.5p135 at 1.1793-o)
> No matter if what i try to configure(nothing, qos lowdelay, qos throughput,
> qos cs5) the packet get send with tos==0xc0.
> Trying to configure "qos 184" triggers a error in log:
> Oct  2 13:41:00 hjj ntpd[65100]: syntax error, unexpected T_Integer, expecting T_String
> Oct  2 13:41:00 hjj ntpd[65100]: parse error /etc/ntp.conf line 22 ignored
> so I am confident that the qos line can be read.
> Is that a problem specific to 4.2.5p135 at 1.1793-o?
> Is it a FreeBSD problem? (Do it work on other platforms?)
> I have been trying to read the code. I have not been able to figure out where
> "CONF_QOS_*" gets translated to the actual values. A pointer please.
> It looks as "EF"(http://www.iana.org/assignments/dscp-registry/) is not one of
> the supported values. I am missing that value. Or a possibility to specify any
> value.
> /hjj
> _______________________________________________
> questions mailing list
> questions at lists.ntp.org
> https://lists.ntp.org/mailman/listinfo/questions

More information about the questions mailing list