[ntp:questions] Source address in response not the same as target address in request

Danny Mayer mayer at ntp.isc.org
Fri Oct 10 03:03:58 UTC 2008


Phil_Newlon at wendys.com wrote:
> I have NTP server running on two Red Hat boxes.  Each box has a primary
> address on eth0, and share a virtual IP address that is managed by linux-ha
> heartbeat.
> 
> NTP requests sent to the virtual IP address are responded to by the primary
> address of eth0 on the server that is handling requests at the time.  Thus,
> if I execute an "ntpdate -q 10.0.0.1" where 10.0.0.1 is the virtual IP of
> eth0:0 and 10.0.0.2 is the IP of eth0, the response is sourced from
> 10.0.0.2.  Thus, the ntpdate query fails with the message "no server
> suitable for synchronization found".
> 
> I found this thread
> http://lists.ntp.isc.org/pipermail/questions/2007-December/016262.html that
> touches on the subject.
> 
> I found another thread that states:
> 
> pick up a version 4.2.4p2 or above:
> ...
> ntpd will ALWAYS bind to all interface addresses but each interface address
> can be Enabled or Disabled. Enable means packets will be received and
> processed
> by the packet reception logic. Disable means that these packets are dropped
> right away
> 
> I am running ntpd 4.2.0a which is the version that comes with RHEL 4 Update
> 6.
> 
> So, if I read this correctly, I should be able to upgrade to 4.2.4x and
> configure NTP to not bind to eth0, so it will receive and respond to
> requests only on the virtual interface eth0:0?
> 
> Thanks!
> 
> Phil

Noone appears to have answered you and I've been too busy to respond.

The general answer is no. It binds to all addresses but use of the -L
option will mean that it ignores anything not received on :0 interfaces
which is what I think you are saying. An enhancement that I have worked
on will allow you to specify the addresses to listen on and to send on.
It's not ready yet.

Danny




More information about the questions mailing list