[ntp:questions] ntp clients out of sync with server

Unruh unruh-spam at physics.ubc.ca
Tue Oct 28 22:03:26 UTC 2008


"naihong at gmail.com" <naihong at gmail.com> writes:

>I know 127.127.1.0 should appear in any clients'  configure file. But

That should read "...should NEVER appear".

>without this statement, the display from ntpq -p,  only display the
>client out of sync with server. I mean tally '*' is missing from

None. 

>server, I did not know which time the client  followed.  So add
>127.127.1.0, just make sure the client sync to its own clock. At
>beginning, I just follow  previous posts, use the simplest
>configuration for orphan mode

Why in the world would you want it to sync to its own clock? 
If it is not syncing to the server, THAT is the problem that needs to be
solved, not some problem that there is no * in ntpq. 

What comes out of peerstats once you get rid of the local clock?



>server's ntp.conf
>driftfile "C:\Program Files\NTP\etc\ntp.drift"
>tos orphan 10

>client's ntp.conf
>driftfile "C:\Program Files (x86)\NTP\etc\ntp.drift"
>server 10.200.98.51 iburst

>But this doesn't work. The clients cannot follow server's time after
>about one day running.

What kind of clients are they? If ntp finds the client is too far off the
server, it gives up and does not try anymore. 

So, start up ntpd -g with the server, and then look at the peerstats file
to see what is happening to the offset. Then look at the loopstats file as
well. 
Also tell us which operating system you are using. And which version of
ntpd




>On Oct 28, 12:33=A0pm, Steve Kostecke <koste... at ntp.org> wrote:
>> On 2008-10-28, naih... at gmail.com <naih... at gmail.com> wrote:
>>
>> > ... time island ...
>>
>> [snip]
>>
>>
>>
>> > I select the orphan mode. After the server and clients start up. At
>> > first, the clents can sync to server's clock. But after 1 day, all 3
>> > clients begin to sync to its local clock, not the server.
>>
>> > The output of ntpq -p is,
>>
>> > remote =A0 =A0 =A0 =A0refid =A0 =A0st t when poll reach delay offset ji=
>tter
>> > =3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
>=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=
>=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D
>> > 10.200.98.51 =A0 =A0 =A0 127.0.0.1 5 u =A0105 =A0256 =A0377 =A00.299 -1=
>.886 =A00.591
>> > *LOCAL(0) =A0 =A0 .LOCL. =A0 12 l =A0 23 =A0 64 =A0377 =A00.000 =A00.00=
>0 =A00.001
>>
>> > The ntp.conf on server is,
>> > driftfile "C:\Program Files\NTP\etc\ntp.drift"
>> > tos orphan 5
>>
>> > The ntp.conf on all 3 clients is(except the drift file location),
>>
>> > driftfile "C:\Program Files (x86)\NTP\etc\ntp.drift"
>> > server 10.200.98.51 iburst
>> > server 127.127.1.0
>> > fudge 127.127.1.0 stratum 12
>>
>> The "clients" should not be using the Undisciplined Local Clock.
>>
>> > logconfig =3D all
>> > logfile "C:\Program Files (x86)\NTP\etc\ntp.log"
>> > statsdir "C:\Program Files (x86)\NTP\etc\log\"
>> > statistics loopstats peerstats clockstats
>> > filegen loopstats file loopstats type day enable
>> > filegen peerstats file peerstats type day enable
>> > filegen clockstats file clockstats type day enable
>>
>> > At beginning, the configuration file on client has only first 2 lines,
>> > the lines from server 127.127.1.0 were added for debugging purpose.
>>
>> That is a misuse of the Undisciplined Local Clock.
>>
>> > The same thing happened two years ago, on different computer hardware.
>> > At that time,I select undiscipline clock on server, and want 5 clients
>> > sync to server. But after days running, the clients out of sync with
>> > server, chasing their own clock. So I have to disable ntpd, and add
>> > ntpdate to crond to sync the time by force.
>>
>> > Could any one give me some clues on this issue.
>>
>> Don't use the Undisciplined Local Clock on any ntpd which does not serve
>> time to others.
>>
>> --
>> Steve Kostecke <koste... at ntp.org>
>> NTP Public Services Project -http://support.ntp.org/




More information about the questions mailing list