[ntp:questions] ntp clients out of sync with server

David Woolley david at ex.djwhome.demon.co.uk.invalid
Wed Oct 29 08:08:37 UTC 2008

naihong at gmail.com wrote:

> The output from ntpq -c"rv":

I asked you to do ntpq -c"rv nnnnn"
where nnnnn is the number given by ntpq -c"assoc"
for the relevant server.

However, this output does indicate that you are synchronised to
something other than the local clock.  You need to run the command
when the system is broken.

> assID=0 status=0644 leap_none, sync_ntp, 4 events, event_peer/
> strat_chg,
> version="ntpd 4.2.4p5 at beijing-o Sep 01 9:15:56 (UTC+02:00) 2008
> (10)",
> processor="unknown", system="WINDOWS/NT", leap=00, stratum=6,
> precision=-20, rootdelay=0.304, rootdispersion=58.322, peer=46864,
> refid=,
> reftime=ccb22e3c.45338a42  Tue, Oct 28 2008 17:35:08.270, poll=6,
> clock=ccb22eb8.2242d2bb  Tue, Oct 28 2008 17:37:12.133, state=4,
> offset=-33.131, frequency=-47.242, jitter=10.226, noise=21.119,
> stability=0.104, tai=0
>> If you have any w32time servers upstream of you, please note that
>> w32time doesn't honour the maximum distance heuristic, so will report a
>> low stratum number even when the root dispersion is impossibly high,
>> because the server hasn't been synchronised for many days, e.g we have
>> one in the office that is reporting stratum three, even though it has
>> not been synchronised for so long that the time is almost 7 seconds out.
> w32time has been disabled on all windows based computer, no matter
> server or client. I have tested ntpd in pure linux environment before,
> both server/client are linux, and have no internet connection. It
> seems clients can find the server has untrusted time and refuse to
> sync with it after running a period of time(about 1 day).
>>> server, I did not know which time the client  followed.  So add
>>>, just make sure the client sync to its own clock. At
>> Clients are ALWAYS synchronised to their own clock (for NTPv4)!

More information about the questions mailing list