[ntp:questions] ntpd service doesn't connect to remote servers on Windows XP

Heiko Gerstung heiko.removethistext.gerstung at meinberg.de
Wed Apr 1 11:27:04 UTC 2009

David J Taylor schrieb:
> Folks,
> I'm looking for suggestions here.  For the last day, I've been trying on 
> and off to help someone get the Meinberg installation of NTP working.  
> It appears to install correctly, and the service starts, but ntpq -p 
> shows all remote servers in INIT with a reach of zero.  No connectivity, 
> it seems.  However, the chap can quite happily type from the 
> command-line: ntpq -p <remote> and get data from the remote server, so I 
> take it that UDP packets on port 123 are passing though his system OK, 
> and therefore that ntpd should connect.  No chance ntpq runs TCP?  He 
> has checked his firewall, and both ntpq.exe and ntpd.exe are allowed for 
> incoming and outgoing, all protocols, all addresses.  He tried running 
> briefly with the firewall disabled.  Still no connects seen by ntpq -p.

Can you try to run ntpdate -q <IP of remote server> on the machine and 
check if that works? If not, try ntpdate -qu <IP> to use an unprivileged 
port. You would need to stop the NTP service on that machine first (net 
stop ntp).

> Although the NTP service starts OK, I'm wonder if it needs some special 
> right to connect to the network as a service - although I would have 
> thought that the Meinberg installer would have granted whatever 
> privileges were required.  I'm getting him to send the event log as a 
> text file, but I'm wondering what obvious things I might have missed, 
> and what the next fault-finding steps might be.

The installer grants the user the required privileges. You can always 
try and install the NTP service using the SYSTEM account which has full 

It could be helpful to see the output of "ntpq -p" and "ntpq -c rv <id>" 
where <id> is the association ID of one of the remote servers. This id 
can be found out using "ntpq -c as" .. and yes, the event log would be 
helpful as well.

Best Regards,

> Thanks,
> David

More information about the questions mailing list