[ntp:questions] NTPD Run

Dave Hart davehart at gmail.com
Tue Jul 28 15:57:32 UTC 2009

On Tue, Jul 28, 2009 at 1:03 AM, nasa138 wrote:
> 5) run ntpd, by entering ntpd at the prompt
> What I expect to see is some printf statement that I added, but
> nothing happened with command "ntpd". I doubt that I have run ntpd
> correctly. If not, what's the correct way to run ntpd. I tried to run
> with "ntpd -d". But somehow -d is no longer an option. I believe it's
> the option to turn on the debug mode.

There are two options to set the debug trace output level, and both
imply -n / --nofork, as Danny mentioned.  -d increments the debug
level (which starts at 0) while -D# sets the debug trace to #.

Be aware support for debug output is only present if configured.  When
ntpd is build after ./configure --disable-debugging, it simply does
not understand either -d or -D options.  You might have been invoking
ntpd from the path, and that ntpd might have been configured without
debugging code.

You might try:

./ntpd -d

If -d is still not accepted, try

./ntpd --version

Assuming you want to use /etc/ntp.conf, you may not need any other
command-line options aside from -d or -D1.

Dave Hart

More information about the questions mailing list