[ntp:questions] Fwd: Troubleshooting who's at fault

Larry Brigman larry.brigman at gmail.com
Thu Jun 25 00:16:40 UTC 2009


Sorry the list doesn't have the correct reply to info.
---------- Forwarded message ----------
From: Larry Brigman <larry.brigman at gmail.com>
Date: Wed, Jun 24, 2009 at 5:14 PM
Subject: Re: [ntp:questions] Troubleshooting who's at fault
To: Ronaldo Mexico <ronaldo.hawk.mexico at gmail.com>


On Wed, Jun 24, 2009 at 4:11 PM, Ronaldo Mexico <
ronaldo.hawk.mexico at gmail.com> wrote:

> I've tried various searches using google and hear in the group to see
> if someone has run into something similar, but the only people who
> have questions similar to mine never got answered, so I'm hoping
> bringing it up again with a bit more detail will help get it solved.
>
> We have physical NTP servers from Brandywine (Brandywine PTS) and up
> until now, we've never had a problem using them as our NTP server.
> The operating systems that have successfully worked with them in the
> past are:
> Windows 2000 (running on pretty much PC hardware)
> Windows XP (running on pretty much PC hardware)
> Solaris 8 (running on native Sun hardware and a Rave Systems)
>
> What I'm running into now is that we are switching operating systems
> for our servers to Red Hat Enterprise Linux 5.  It is running on
> pretty much PC hardware.
>
.....

> And this is my ntp.conf file:
> [root at screamer-dc1 init.d]# cat /etc/ntp.conf
> server  127.127.1.0 # local clock
> fudge   127.127.1.0 stratum 10
>
> server 147.159.120.131 minpoll 4 maxpoll 10 prefer iburst # ntp -
> brandywine
>
> driftfile /var/lib/ntp/drift
> logfile /var/log/ntp.log
>
>
> **********************************************************************************************
> The RHEL operating system has no problems syncing with other stratum 2
> servers (I've used public servers), just with this particular unit,
> which has had no other compatibility issues.
>
> The variables in this problem:
> 1.  The operating system/ntpd daemon
> 2.  The physical clock hardware in the machine
>
It might be that the PTS doesn't like version 4 ntp being sent to it.  Add
'version 2' on
the server line.

Other things to look at.

What does your /etc/sysconfig/ntpd file look like?
Do you have anything in /etc/ntp/step-tickers?

Anything funny in the log files?
Have you tried increasing the debug level to see if there is anything else
that can give you
a clue.



More information about the questions mailing list