[ntp:questions] ntpd/refclock_local.c

mval mjjunk19 at gmail.com
Mon Aug 9 21:09:54 UTC 2010


On Aug 7, 9:37 pm, Danny Mayer <ma... at ntp.org> wrote:
> On 8/5/2010 5:53 PM, mval wrote:
>
> > Upgrading ntp from 4.2.0 to 4.2.6p1.
>
> > System receives time via broadcast over the wildcard interface.
>
> That should not be happening. ntpd should be creating it's own receiving
> interface for broadcast packets. The wildcard interface cannot be used
> for autokey and under normal circumstances the code will not configure
> the wildcard interface to receive broadcast packets. If you have
> evidence that it is doing so, please file a bug report along with
> details of the O/S you are using. As I recall only Windows NT 4.0 needed
> to use the wildcard interface.

Danny,

Thank you for the reply.  ntpd will not sync with the broadcast server
unless I open the wildcard interface.  So if my ntpd.conf file looks
like this:
**********
broadcastclient
enable bclient
server ******* minpoll 4 maxpoll 4 iburst burst
fudge ******* stratum 12 refid LCL
calldelay 2
driftfile ../ntpd.drift
pidfile ../ntpd.pid
tinker panic 10
disable stats
disable kernel
disable auth
***********
ntpd selects the local clock.  In this state, I've already done a
tcpdump and can see the broadcast messages coming in.  Additonally, I
can ping the broadcast servers.  I've already checked for firewall
issues and there are none.  Again, everything was functionally
correctly when running 4.2.0.

I have to add the following two lines to my .conf file for ntpd to
sync with the broadcast server:
**********
interface listen wildcard
interface listen all
***********

So in my situation, I have to listen on the wildcard interface in
order to sync with the broadcast server.

Thanks,
mval




More information about the questions mailing list