[ntp:questions] ntptime didn´t show ppssignal

Heiko Gerstung heiko.removethistext.gerstung at meinberg.de
Mon Aug 30 07:46:25 UTC 2010


Sorry to ask this, but you double-triple checked that you are running
the correct, self-complied binary, right? After a "make install" it
should be in /usr/local/sbin while Ubuntu's ntpd is in /usr/sbin ...

Regards,
  Heiko



Am 27.08.2010 15:40, schrieb Burkhardt, Frank:
> Dear Heiko,
> 
> thanks for your hint.
> 
>> You definitely have no ATOM_PPS refclock support in your ntpd but it
>> looks like your kernel supports PPS and it works fine. Please re-run
>> configure and check its output. I would suspect that the configure
>> script looks for certain include files in your kernel header dir(s) and
>> does not find them. That results in disabling ATOM at configuration time
>> (can be verified by looking into the generated config.h file of NTP).
> 
> I checked the configure process but it has no errors, concerning ATOM:
> 
> "checking ATOM PPS interface... yes"
> 
> Also config.h shows:
> 
> #define CLOCK_ATOM 1
> 
> And config.log displays:
> 
> configure:29089: running /bin/bash ./configure --disable-option-checking '--prefix=/usr/local'  '--enable-ATOM' --cache-file=/dev/null --srcdir=.
> ac_cv_var_atom_ok=yes
> 
> Make shows no serious errors.
> 
> Cheers,
> Frank
> 
> 
> 
> 
>> -----Ursprüngliche Nachricht-----
>> Von: questions-bounces+frank.burkhardt=fokus.fraunhofer.de at lists.ntp.org
>> [mailto:questions-
>> bounces+frank.burkhardt=fokus.fraunhofer.de at lists.ntp.org] Im Auftrag
>> von Heiko Gerstung
>> Gesendet: Freitag, 27. August 2010 14:12
>> An: questions at lists.ntp.org
>> Betreff: Re: [ntp:questions] ntptime didn´t show ppssignal
>>
>> Hi Frank,
>>
>> Am 23.08.2010 14:30, schrieb Burkhardt, Frank:
>>> Dear Listmembers,
>>>
>>> first of all sorry for my bad english, but I'm not a native speaker
>> and not trained so well ;-)
>>>
>>> I tried to get ntpd working with a pps signal (atom driver) under
>> Ubuntu 10.04 since one week without success. I'm using a self compiled
>> kernel 2.6.34.3 with pps support and pps_client ldisc built in. "pstest"
>> shows following data, so I think it is generally working:
>>>
>>> root at chaser:/home/fast# /export/pps-tools/ppstest /dev/pps0
>>> trying PPS source "/dev/pps0"
>>> found PPS source "/dev/pps0"
>>> ok, found 1 source(s), now start fetching data...
>>> source 0 - assert 1282565685.198781684, sequence: 352669 - clear
>> 1282213025.923967757, sequence: 10
>>> source 0 - assert 1282565686.198843801, sequence: 352670 - clear
>> 1282213025.923967757, sequence: 10
>>> source 0 - assert 1282565687.198921096, sequence: 352671 - clear
>> 1282213025.923967757, sequence: 10
>>
>> That shows that your PPS support is working fine on kernel level.
>>
>>> I compiled ntpd with --enable-atom option, but when I start ntpd it
>> shows following error in the log:
>>>
>>> 16 Aug 10:36:00 ntpd[17210]: refclock_newpeer: clock type 22 invalid
>> This clearly shows that you have no ATOM_PPS refclock support.
>>
>>> 16 Aug 10:36:00 ntpd[17210]: 127.127.22.0 interface 127.0.0.1 ->
>> (null)
>>>
>>> But i think the problem has maybe nothing to do with ntpd directly so
>> far, because ntptime shows only PLL, NANO and not PPSXXXX in the status
>> field:
>>>
>>> ntp_gettime() returns code 0 (OK)
>>>   time d01ce7a9.c30c885c  Mon, Aug 23 2010 14:27:21.761, (.761910415),
>>>   maximum error 257004 us, estimated error 458 us
>>> ntp_adjtime() returns code 0 (OK)
>>>   modes 0x0 (),
>>>   offset -42.572 us, frequency 17.326 ppm, interval 1 s,
>>>   maximum error 257004 us, estimated error 458 us,
>>>   status 0x2001 (PLL,NANO),
>>>   time constant 6, precision 0.001 us, tolerance 500 ppm
>> I do not see this in the output of ntptime on my (PPS-enabled) system, I
>> guess ntptime does not know about the newer PPS implementation.
>>
>>> So is the kernel not detecting the PPS, even though ppstest shows the
>> signal etc.?
>>>
>>> I don´t know how I can proceed, miss I something else, do someone have
>> any hints for me?
>>>
>>> Many thanks in advance and kind regards from Berlin,
>>> Frank
>>>
>>
>> You definitely have no ATOM_PPS refclock support in your ntpd but it
>> looks like your kernel supports PPS and it works fine. Please re-run
>> configure and check its output. I would suspect that the configure
>> script looks for certain include files in your kernel header dir(s) and
>> does not find them. That results in disabling ATOM at configuration time
>> (can be verified by looking into the generated config.h file of NTP).
>>
>> Best Regards,
>>   Heiko
>>
>> _______________________________________________
>> questions mailing list
>> questions at lists.ntp.org
>> http://lists.ntp.org/listinfo/questions




More information about the questions mailing list