[ntp:questions] Palisade Reference Clock

George Ross gdmr at inf.ed.ac.uk
Tue Aug 31 06:46:24 UTC 2010


> I am new to Reference Clocks, and I am just simply stumped now.
> 
> I have a Palisade smart antenna, with firmware version 7.12 (I did an
> upgrade from the Trimble website).
> Previous to this I had 7.10, and it worked correctly, my model number is
> 26664-10 so I am able to have event trigger.

We have an Acutime 2000, which has pretty much just worked since we bought 
it in 2005.  We haven't felt the urge to do anything to the firmware, and 
I've no idea what it's running -- whatever was current at the time.

> Now I am just getting ckl_noreply 
> 
> My /etc/ntpd.conf is as follows:
> 
> server 127.127.29.0     prefer            # Trimble acutime 2000
> fudge  127.127.29.0 stratum 1
> fudge  127.127.29.0 time1 0.020
> #fudge  127.127.29.0 flag2 1
> 
> 
> No matter what if I have fag2 on or off, I still get clk_noreply.

Have you tried running the (Windows-only?) configuration tool?  What does it
say about the acutime?  Remember to run it on the *other* RS232 port on the
bottom-end converter box from the one you normally connect ntpd to.

Have you tried running the daemon in debugging mode, per the driver29.html 
page?  What does that say?  We found that quite useful on the one occasion 
where we had any problem with our unit.

The only occasion that I recall having any problems at all was when we 
replaced the linux host with a faster machine, and we came to the 
conclusion that either the serial hardware was "different" or the new box 
was simply now pulsing the timestamp-me line too quickly.  As a quick hack 
workaround I simply duplicated the two ioctl()s in the driver which toggled 
the relevant control line.  It might be worth checking whether there's 
anything in the code like that...
-- 
Dr George D M Ross, School of Informatics, University of Edinburgh
        10 Crichton Street, Edinburgh, Scotland, EH8 9AB
Mail: gdmr at inf.ed.ac.uk   Voice: +44 131 650 5147   Fax: +44 131 650 6899
 PGP: 1024D/AD758CC5  B91E D430 1E0D 5883 EF6A  426C B676 5C2B AD75 8CC5

The University of Edinburgh is a charitable body, registered in
Scotland, with registration number SC005336.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 236 bytes
Desc: not available
URL: <http://lists.ntp.org/pipermail/questions/attachments/20100831/2510ee27/attachment.pgp>


More information about the questions mailing list