[ntp:questions] problem with ntpd refclock and pps via parallel port

David Lord snews at lordynet.org
Thu Feb 4 23:57:16 UTC 2010

David Lord wrote:
> David Lord wrote:
>> problem with ntpd refclock and  pps via parallel port
>> Hi
>> on system A I had type 22 pps working ok from pps at ttl
>> level to DCD of serial port. This was a bit erratic and
>> temperature sensitive possibly due to mismatch of ttl/rs232
>> levels.
>> on system B, rather than add complication of ttl=>rs232
>> conversion I've connected pps to parallel port and changed
>> symlink to be /dev/pps0 => /dev/lpt0
>> With same NetBSD-5-PPS kernel as on system A, I am getting following 
>> in ntp.log at startup:
>>   refclock_atom: /dev/pps0: Interrupted system call
>>   configuration of failed
>> No PPS shown by 'ntpq -p'
>> A google for above here gave some messages from suggesting
>> use of atppc* at isa?, ppbus* at atppc?, pps* at pps?
>> so now I have dmesg with
>>    atppc0 at isa0 ......
>>    atppc0: capabilities=3<INTR,DMA>
>>    ppbus0 at atppc0
>>    lpt0 at ppbus0
>>    pps0 at ppbus0
>> System B, NetBSD-5, doesn't have a refclock, just other
>> ntp servers but ntp docs appear to state this as being ok.
>> On system C, NetBSD-4.0.1, which is working ntp server with
>> MSF clock on serial via DCD, I've just tried link
>> pps0 => lpt0 and have same output from ntpd as from system B.
>> I've since rewired system C with MSF to serial dsr and
>> pps to serial dcd, restarted and ntpq shows
>> SHM(0)/MSFa and PPS(0) and after a short while get +SHM(0)
>> then oPPS(0) with system having drifted > 10ms whilst
>> rewiring and restarting but now back at < 1ms.
>> So does pps really need a refclock and/or does pps via
>> parallel work ok or not on NetBSD-5?

Gave up yesterday on desktop with pps using ppbus and pps0
from parallel port with local ntp server set as preferred.

Tried tonight on different system upstairs with pps using
ppbus from parallel port with gps nmea refclock to RxD.
NMEA showed reachable, then selected and then PPS(0) showed
reachable and eventually selected.

Removed parallel connection and it took some while for
PPS to show change in reach which then dropped from 377 over
a short period to 0. On reconnect of parallel port reach
moved back up to 377.

So at moment looks as though either refclock is essential or
some problem with parallel port on system I tried first.


More information about the questions mailing list