[ntp:questions] Befuddled and confused, again...

Thomas Laus lausts at acm.org
Sun Feb 14 15:22:20 UTC 2010


On 2010-02-14, Dave Baxter <spam at goes.nowhere.com> wrote:
> Hi All.
>
> Been trying (again) to setup a FreeBSD GPSDNTP server, as I want to use 
> the currently used Win2k (With the Meinberg binary etc) box for 
> something else, having found that running anything else "significant" on 
> it, "distrubes" the NTPD system somewhat.  Nothing wrong with the 
> Meinberg system (far from it in fact) it's just that I need that machine 
> to replace an older PC that has finaly expired, so as I have another 
> with no OS on it, I thought I'd go the FreeBSD route this time.
>
A good move!

> I did manage to follow through the instructions about a year ago, and 
> they worked fine on the PC I hijacked at that time to play with (someone 
> at work eventualy threw out that PC while I wasn't looking, sadly it was 
> too badly damaged in the process to reclaim!)  Now trying to retrace my 
> stept I get errors trying to rebuild the kernel to support PPS.
>
Your selection of version 5.4 is pretty old.  It should work, but using
the latest 8.0 release is more likely to have a longer supported
lifetime.  Get the disk 1 iso from one of the FreeBSD mirrors and
install it.  Use the FreeBSD official site instructions rather than
something that was written a few years ago.

> The errors I'm getting occur when insalling the new kernel, relating to 
> missing files or directories.  Indeed, what it is looking for, isnt 
> there.   Also, I can't find /etc/make.conf!   What is the correct full 
> path to that file?  I suspect this is the root (pun intended) cause of 
> the trouble.  At the moment I have an etc directory listed in /usr/src 
> but that does not have a make.conf in there.
>
The /etc/make.conf does not exist until you create one.  It is used to
customize your build environment for any optimization switches that you
want to enable or items that you want to override from the defaults.
Not having an /etc/make.conf should not be a problem.  If you can't
build a system from the one that was provided on your distribution media
, it is a problem that is best solved on a FreeBSD newsgroup.

> Interestingly 'make buildkernel ...' appears to work fine, it completes 
> with no error that I can tell anyway.
>
> But 'make installkernel ...' fails with the directory not found errors.
>
Have you updated your source after you installed FreeBSD?  The "world"
and kernel are a complete package.  You can't update and build the
just the kernel if you have made a significant change to the rest of the
source files that affect the balance of the system.  Get the version 8.0
release, install it along with the source code on the CD.  This will
make all of your installed files consistant between the kernel and the
rest of the "world".  The option "PPS_SYNC" is only required if you have
a reference clock that has a pulse-per-second timing signal.  It is not
required just to run ntp.

Tom
-- 
Public Keys:
PGP KeyID = 0x5F22FDC1
GnuPG KeyID = 0x620836CF




More information about the questions mailing list