[ntp:questions] Befuddled and confused, again...

David Lord snews at lordynet.org
Mon Feb 15 01:18:12 UTC 2010

unruh wrote:
> On 2010-02-14, David Lord <snews at lordynet.org> wrote:

>> That might be a Linux specific feature of gpsd.
>> Man page mentions Linux version of gpsd detecting PPS on
>> serial DCD line otherwise best accuracy around 10ms.
>> On NetBSD I've only tried gpsd + shm with GlobalSat BR-304
>> and that doesn't have PPS out and couldn't get anything near
>> 10ms from it having tried with large mindist and various
>> fudge times. It's on my todo list to try with the Garmin
>> gps-18x-LVC in case the PPS DCD support is working on NetBSD
>> to compare with using NMEA/PPS and NMEA + ATOM drivers.
> There is also the shmpps program, which detects pps either on the serial
> or the parallel port and uses the shm driver to deliver the time offset.
> Something else is needed to determine the "seconds" while shmpps
> determines the usec using the serial or parallel port interrupt drivers. 
> I do not know if shmpps works out the box on Freebsd, but it should not
> be hard to adapt, assuming bsd supports the shm refclock driver.

I've tried radioclkd, radioclkd2 for DCF/MSF and gpsd, all with
shm driver on NetBSD so would expect it to work same or
better with FreeBSD probably having more recent ntpd.

I think I downloaded shmpps some while back and forgot about it
so I'll dig that out since parallel port seems usable for
PPS on NetBSD although doesn't seem usable with NMEA driver.
With ATOM driver I get errors: "kernel time sync error 0x2307
whilst oPPS(0)     offset -0.001  jitter  0.002
and    GPS_NMEA(0) offset -32.881 jitter 11.134

With MSF receiver using radioclockd2 + shm driver I have
no errors but again with ATOM driver I get same error as
above, sometimes repeating each second but other times
gaps of 30min or more.


More information about the questions mailing list