[ntp:questions] Maximum time2 fudge value for NMEA refclock?

jimmyterrence jimmyterrence at gmail.com
Fri Jul 16 19:01:41 UTC 2010

On Jul 16, 9:45 am, "David J Taylor" <david-
tay... at blueyonder.co.uk.invalid> wrote:
> "jimmyterrence" <jimmyterre... at gmail.com> wrote in message
> news:1c01938f-d43e-4dea-a143-45e096d318fd at j8g2000yqd.googlegroups.com...
> []
> > If it was triggering on the wrong edge of the pps signal, wouldn't it
> > be off of the rest of the servers by the length of the pulse? I think
> > that it's triggering properly.
> Agreed.
> > My 555 ms fudge, from the config file.
> > #gpsd PPS
> > server minpoll 4 maxpoll 4 prefer
> > fudge refid PPS
> > #gpsd
> > server minpoll 4 maxpoll 4
> > fudge refid NMEA flag4 1 time1 0.555
> > I stopped gpsd to check and make sure I had set the outputs properly,
> > but it shows just one sentence, GPRMC.
> > $GPRMC,130803,A,4416.2422,N,07823.4033,W,000.0,143.4,160710,011.6,W*71
> I thought that the NMEA driver just needed to be to the nearest second
> when you had a PPS signal?  As you have good Internet servers, there may
> not even be a need for the NMEA driver at all (at least with recent
> versions of PPS, but I'm outside my scope of knowledge here).  I run
> FreeBSD, ntpd 4.2.4p5-a (1),  and my configuration file has:
> server    mode 0  minpoll 4 maxpoll 4  prefer
> fudge    flag1 1 flag3 1 refid PPS
> The PPS is built into the type 20 driver.  Pity you can't use that.
> Cheers,
> David

I tried to compile PPS into the kernel on a Debian Squeeze system. I
read that 2.6.34 doesn't require patching for PPS anymore.
Unfortunately, I'm running it on a 1 GB CF drive, so I don't have the
source directory anymore. I know, I should invest $10 in a 4 Gig card
so that it will all fit on the drive. I made dpkgs for the kernel
images and headers and then transferred them to the CF card. Anyway,
here is the relevant portion of my kernel config file:

# PPS support
# CONFIG_PPS_DEBUG is not set

# PPS clients support

I created a symlink called gps0 to my serial port ttyS0, because it
told me that in the logs when I tried to start up ntpd without it.

Can somebody who uses the NMEA driver in linux tell me if there is
something else that I should have compiled in? gpsd works fine, but
every time I switch to the NMEA type 20 driver, it doesn't work. It
doesn't seem to write anything to the system logs, or clockstats

More information about the questions mailing list